{"answers":{"affected":"4 open source packages ship an affected version, including highcharts.","exploited":"There is no known exploitation of GHSA-gr4j-r575-g665 in the wild and no public exploit code.","fix":"Upgrade highcharts to a fixed version for your release line: 7.2.2 or 8.1.1.","what":"GHSA-gr4j-r575-g665 is a cross-site scripting vulnerability in highcharts, published on 25 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-gr4j-r575-g665 and fix it if it is affected.\n\nWhat it is: GHSA-gr4j-r575-g665 is a cross-site scripting vulnerability in highcharts, published on 25 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-gr4j-r575-g665 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- highcharts (npm): affected all versions; fixed in 7.2.2\n- highcharts (npm): affected all versions; fixed in 7.2.2\n- highcharts (npm): affected from 8.0.0; fixed in 8.1.1\n- highcharts (npm): affected from 8.0.0; fixed in 8.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-gr4j-r575-g665/ (Markdown: https://insights.sbomify.com/GHSA-gr4j-r575-g665/index.md)","id":"GHSA-gr4j-r575-g665","markdown":"https://insights.sbomify.com/GHSA-gr4j-r575-g665/index.md","name":"GHSA-gr4j-r575-g665","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript charting library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victims' browsers via unsanitized href values in Highcharts links, requiring user interaction.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `highcharts` prior to 7.2.2 or 8.1.1 are vulnerable to Cross-Site Scripting (XSS).  The package fails to sanitize `href` values and does not restrict URL schemes, allowing attackers to execute arbitrary JavaScript in a victim's browser if they click the link.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in highcharts","id":"GHSA-gr4j-r575-g665","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["7.2.2"],"introduced":["0"],"last_affected":[],"package":"highcharts","purl":null,"source":"GHSA-gr4j-r575-g665"},{"ecosystem":"npm","fixed":["7.2.2"],"introduced":["0"],"last_affected":[],"package":"highcharts","purl":"pkg:npm/highcharts","source":"GHSA-gr4j-r575-g665"},{"ecosystem":"npm","fixed":["8.1.1"],"introduced":["8.0.0"],"last_affected":[],"package":"highcharts","purl":null,"source":"GHSA-gr4j-r575-g665"},{"ecosystem":"npm","fixed":["8.1.1"],"introduced":["8.0.0"],"last_affected":[],"package":"highcharts","purl":"pkg:npm/highcharts","source":"GHSA-gr4j-r575-g665"}],"products":null,"published":"2020-08-25","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript in victims' browsers via unsanitized href values in Highcharts links, requiring user interaction.","url":"https://insights.sbomify.com/GHSA-gr4j-r575-g665/"}