{"answers":{"affected":"2 open source packages ship an affected version, including usd-core.","exploited":"There is no known exploitation of GHSA-grjp-54v3-c442 in the wild and no public exploit code.","fix":"Upgrade usd-core to 25.11 or later.","what":"GHSA-grjp-54v3-c442 is an use after free vulnerability in usd-core, published on 29 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-grjp-54v3-c442 and fix it if it is affected.\n\nWhat it is: GHSA-grjp-54v3-c442 is an use after free vulnerability in usd-core, published on 29 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-grjp-54v3-c442 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- usd-core (PyPI): affected all versions; fixed in 25.11\n- usd-core (PyPI): affected all versions; fixed in 25.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-grjp-54v3-c442/ (Markdown: https://insights.sbomify.com/GHSA-grjp-54v3-c442/index.md)","id":"GHSA-grjp-54v3-c442","markdown":"https://insights.sbomify.com/GHSA-grjp-54v3-c442/index.md","name":"GHSA-grjp-54v3-c442","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenUSD library","requires_auth":"none","summary":"A use-after-free vulnerability in OpenUSD allows remote code execution when parsing malicious files, requiring user interaction to open the file.","user_interaction":"required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"# Patch\nThis is fixed with [commit b953092](https://github.com/PixarAnimationStudios/OpenUSD/commit/b9530922b6a8ea72cd43661226b693fff8abbe4c), with the fix available in OpenUSD 25.11 and onwards.\n\n# Summary\nWe have been advised by Zero Day Initiative that our usage of the USD framework may constitute a Use-After-Free Remote Code Execution Vulnerability. They have sent us the attached file illustrating the issue. Indeed, we see a use after free exception when running the file through our importer with an address sanitizer.\n\n[zdi-23709-poc0.zip](https://github.com/user-attachments/files/17474297/zdi-23709-poc0.zip)\n\nThanks in advance.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenUSD File Parsing Use-After-Free Remote Code Execution Vulnerability","id":"GHSA-grjp-54v3-c442","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"use_after_free","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["25.11"],"introduced":["0"],"last_affected":[],"package":"usd-core","purl":null,"source":"GHSA-grjp-54v3-c442"},{"ecosystem":"PyPI","fixed":["25.11"],"introduced":["0"],"last_affected":[],"package":"usd-core","purl":"pkg:pypi/usd-core","source":"GHSA-grjp-54v3-c442"}],"products":null,"published":"2025-10-29","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A use-after-free vulnerability in OpenUSD allows remote code execution when parsing malicious files, requiring user interaction to open the file.","url":"https://insights.sbomify.com/GHSA-grjp-54v3-c442/"}