# GHSA-gv8r-9rw9-9697: Traefik affected by TLS ClientAuth Bypass on HTTP/3

> Traefik allows bypassing TLS ClientAuth on HTTP/3, enabling unauthorized access when mutual TLS is configured.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Also known as:** GO-2026-4530

## What is GHSA-gv8r-9rw9-9697?

GHSA-gv8r-9rw9-9697 is an authentication bypass vulnerability in github.com/traefik/traefik, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary

There is a potential vulnerability in Traefik managing HTTP/3 connections.

More details in the [CVE-2025-68121](https://nvd.nist.gov/vuln/detail/CVE-2025-68121).

## Patches

- https://github.com/traefik/traefik/releases/tag/v2.11.37
- https://github.com/traefik/traefik/releases/tag/v3.6.8

## Workarounds

No workaround

## For more information

If you have any questions or comments about this advisory, please [open an issue](https://github.com/traefik/traefik/issues).

## Which versions are affected by GHSA-gv8r-9rw9-9697?

9 open source packages ship an affected version, including github.com/traefik/traefik, github.com/traefik/traefik/v2 and github.com/traefik/traefik/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/traefik/traefik` | Go | All versions | None |
| `github.com/traefik/traefik` | Go | All versions to 1.7.34 | None |
| `github.com/traefik/traefik` | Go | All versions to 1.7.34 | None |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.37 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.37 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.37 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.6.8 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.6.8 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.6.8 |

## How do I fix GHSA-gv8r-9rw9-9697?

Upgrade to a fixed version.

## Is GHSA-gv8r-9rw9-9697 being exploited?

There is no known exploitation of GHSA-gv8r-9rw9-9697 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-gv8r-9rw9-9697 and fix it if it is affected.

What it is: GHSA-gv8r-9rw9-9697 is an authentication bypass vulnerability in github.com/traefik/traefik, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-gv8r-9rw9-9697 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/traefik/traefik (Go): affected all versions; no fix listed
- github.com/traefik/traefik (Go): affected all versions up to 1.7.34; no fix listed
- github.com/traefik/traefik (Go): affected all versions up to 1.7.34; no fix listed
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.37
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.37
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.37
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.6.8
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.6.8
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-gv8r-9rw9-9697/ (Markdown: https://insights.sbomify.com/GHSA-gv8r-9rw9-9697/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-gv8r-9rw9-9697

---
From sbomify Insights: https://insights.sbomify.com/GHSA-gv8r-9rw9-9697/
Summaries are generated and may contain mistakes; the official description above is the record.
