GHSA-gwj5-3vfq-q992 Import loops in account imports, nats-server DoS
An attacker with an account can crash the NATS server by creating import loops, causing resource exhaustion and denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-gwj5-3vfq-q992?
GHSA-gwj5-3vfq-q992 is a denial of service vulnerability in github.com/nats-io/nats-server, published on 21 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
(This advisory is canonically <https://advisories.nats.io/CVE/CVE-2020-28466.txt>)
Problem Description
An export/import cycle between accounts could crash the nats-server, after consuming CPU and memory.
This issue was fixed publicly in <https://github.com/nats-io/nats-server/pull/1731> in November 2020.
The need to call this out as a security issue was highlighted by snyk.io and we are grateful for their assistance in doing so.
Organizations which run a NATS service providing access to accounts run by untrusted third parties are affected. See below for an important caveat if running such a service.
Affected versions
NATS Server
- Version 2 prior to 2.2.0
- 2.0.0 through and including 2.1.9 are vulnerable.
- fixed with nats-io/nats-server PR 1731, commit 2e3c226729
Impact
The nats-server could be killed, after consuming resources.
Workaround
The import cycle requires at least two accounts to work; if you have open account sign-up, then restricting new account sign-up might hinder an attacker.
Solution
Upgrade the nats-server.
Caveat on NATS with untrusted users
Running a NATS service which is exposed to untrusted users presents a heightened risk.
Any remote execution flaw or equivalent seriousness, or denial-of-service by unauthenticated users, will lead to prompt releases by the NATS maintainers.
Fixes for denial of service issues with no threat of remote execution, when limited to account holders, are likely to just be committed to the main development branch with no special attention.
Those who are running such services are encouraged to build regularly from git.
Which versions are affected by GHSA-gwj5-3vfq-q992?
4 open source packages ship an affected version, including github.com/nats-io/nats-server/v2 and github.com/nats-io/nats-server.
| Package | Affected | Fixed in |
|---|---|---|
github.com/nats-io/nats-server/v2 Go | All versions | 2.2.0 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.2.0 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.2.0 |
github.com/nats-io/nats-server Go | All versions | None |
How do I fix GHSA-gwj5-3vfq-q992?
Upgrade github.com/nats-io/nats-server/v2 to 2.2.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is GHSA-gwj5-3vfq-q992 being exploited?
There is no known exploitation of GHSA-gwj5-3vfq-q992 in the wild and no public exploit code.
Sources
Also known as GO-2022-0398.