{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework1.","exploited":"There is no known exploitation of GHSA-gwpm-pm6x-h7rj in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework1 to 1.7.6 or later.","what":"GHSA-gwpm-pm6x-h7rj is a cross-site scripting vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-gwpm-pm6x-h7rj and fix it if it is affected.\n\nWhat it is: GHSA-gwpm-pm6x-h7rj is a cross-site scripting vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-gwpm-pm6x-h7rj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework1 (Packagist): affected from 1.7.0; fixed in 1.7.6\n- zendframework/zendframework1 (Packagist): affected from 1.7.0; fixed in 1.7.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-gwpm-pm6x-h7rj/ (Markdown: https://insights.sbomify.com/GHSA-gwpm-pm6x-h7rj/index.md)","id":"GHSA-gwpm-pm6x-h7rj","markdown":"https://insights.sbomify.com/GHSA-gwpm-pm6x-h7rj/index.md","name":"GHSA-gwpm-pm6x-h7rj","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"An XSS vulnerability in Zend_Filter_StripTags allows attackers to inject scripts via whitespace in attributes when using attribute whitelisting.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"`Zend_Filter_StripTags` is a filtering class analogous to PHP's `strip_tags()` function. In addition to stripping HTML tags and selectively keeping those provided in a whitelist, it also provides the ability to whitelist specific attributes to retain per whitelisted tag.\n\nThe reporter discovered that attributes that contained whitespace, and in paricular, line breaks, surrounding the attribute assignment operator would not be stripped, regardless of whether or not they were whitelisted. As examples of input affected:\n```\n\u003c!-- newlines before and/or after assignment: --\u003e\n\u003ca href=\"http://framework.zend.com/issues\" onclick\n=\n\"alert('Broken'); return false;\"\u003eIssues\u003c/a\u003e\n```\nWhen passed to the following code:\n```\n$filter = new Zend_Filter_StripTags(array('a' =\u003e array('href')));\n$value  = $filter-\u003e($html);\n```\nthen the \"onclick\" attribute would remain, even though it was not specified in the tag's whitelist. This could open potential cross-site scripting attack (XSS) vectors.\n\n## Recommendations\nIf you were using `Zend_Filter_StripTags` and utlizing the attribute whitelisting functionality, you should immediately upgrade to Zend Framework 1.7.6 or above; regardless, it is always best to run the most current version of the framework.\n\nAlso, if relying on `Zend_Filter_StripTags` to prevent XSS, the only way to reliably do so is to strip all tags, and never to whitelist. If you are whitelisting, you should consider finding a reliable XSS filter through which to run your output; we recommend HTML Purifier.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendFramework Cross-site Scripting vector in `Zend_Filter_StripTags`","id":"GHSA-gwpm-pm6x-h7rj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.7.6"],"introduced":["1.7.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-gwpm-pm6x-h7rj"},{"ecosystem":"Packagist","fixed":["1.7.6"],"introduced":["1.7.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-gwpm-pm6x-h7rj"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An XSS vulnerability in Zend_Filter_StripTags allows attackers to inject scripts via whitespace in attributes when using attribute whitelisting.","url":"https://insights.sbomify.com/GHSA-gwpm-pm6x-h7rj/"}