{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri.","exploited":"There is no known exploitation of GHSA-gx8x-g87m-h5q6 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.13.4 or later.","what":"GHSA-gx8x-g87m-h5q6 is a denial of service vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-gx8x-g87m-h5q6 and fix it if it is affected.\n\nWhat it is: GHSA-gx8x-g87m-h5q6 is a denial of service vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-gx8x-g87m-h5q6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.4\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-gx8x-g87m-h5q6/ (Markdown: https://insights.sbomify.com/GHSA-gx8x-g87m-h5q6/index.md)","id":"GHSA-gx8x-g87m-h5q6","markdown":"https://insights.sbomify.com/GHSA-gx8x-g87m-h5q6/index.md","name":"GHSA-gx8x-g87m-h5q6","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby HTML parser","requires_auth":"none","summary":"An attacker can cause a denial of service by providing ill-formed HTML markup to the Nokogiri library on JRuby, leading to an OutOfMemoryError.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Summary\n\nNokogiri `v1.13.4` updates the vendored `org.cyberneko.html` library to `1.9.22.noko2` which addresses [CVE-2022-24839](https://github.com/sparklemotion/nekohtml/security/advisories/GHSA-9849-p7jc-9rmv). That CVE is rated 7.5 (High Severity).\n\nSee [GHSA-9849-p7jc-9rmv](https://github.com/sparklemotion/nekohtml/security/advisories/GHSA-9849-p7jc-9rmv) for more information.\n\nPlease note that this advisory only applies to the **JRuby** implementation of Nokogiri `\u003c 1.13.4`.\n\n## Mitigation\n\nUpgrade to Nokogiri `\u003e= 1.13.4`.\n\n## Impact\n\n### [CVE-2022-24839](https://github.com/sparklemotion/nekohtml/security/advisories/GHSA-9849-p7jc-9rmv) in nekohtml\n\n- **Severity**: High 7.5\n- **Type**: [CWE-400](https://cwe.mitre.org/data/definitions/400.html) Uncontrolled Resource Consumption\n- **Description**: The fork of `org.cyberneko.html` used by Nokogiri (Rubygem) raises a `java.lang.OutOfMemoryError` exception when parsing ill-formed HTML markup.\n- **See also**: [GHSA-9849-p7jc-9rmv](https://github.com/sparklemotion/nekohtml/security/advisories/GHSA-9849-p7jc-9rmv)","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service (DoS) in Nokogiri on JRuby","id":"GHSA-gx8x-g87m-h5q6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["1.13.4"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-gx8x-g87m-h5q6"},{"ecosystem":"RubyGems","fixed":["1.13.4"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-gx8x-g87m-h5q6"}],"products":null,"published":"2022-04-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service by providing ill-formed HTML markup to the Nokogiri library on JRuby, leading to an OutOfMemoryError.","url":"https://insights.sbomify.com/GHSA-gx8x-g87m-h5q6/"}