# GHSA-gx8x-g87m-h5q6: Denial of Service (DoS) in Nokogiri on JRuby

> An attacker can cause a denial of service by providing ill-formed HTML markup to the Nokogiri library on JRuby, leading to an OutOfMemoryError.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2022

## What is GHSA-gx8x-g87m-h5q6?

GHSA-gx8x-g87m-h5q6 is a denial of service vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

## Summary

Nokogiri `v1.13.4` updates the vendored `org.cyberneko.html` library to `1.9.22.noko2` which addresses [CVE-2022-24839](https://github.com/sparklemotion/nekohtml/security/advisories/GHSA-9849-p7jc-9rmv). That CVE is rated 7.5 (High Severity).

See [GHSA-9849-p7jc-9rmv](https://github.com/sparklemotion/nekohtml/security/advisories/GHSA-9849-p7jc-9rmv) for more information.

Please note that this advisory only applies to the **JRuby** implementation of Nokogiri `< 1.13.4`.

## Mitigation

Upgrade to Nokogiri `>= 1.13.4`.

## Impact

### [CVE-2022-24839](https://github.com/sparklemotion/nekohtml/security/advisories/GHSA-9849-p7jc-9rmv) in nekohtml

- **Severity**: High 7.5
- **Type**: [CWE-400](https://cwe.mitre.org/data/definitions/400.html) Uncontrolled Resource Consumption
- **Description**: The fork of `org.cyberneko.html` used by Nokogiri (Rubygem) raises a `java.lang.OutOfMemoryError` exception when parsing ill-formed HTML markup.
- **See also**: [GHSA-9849-p7jc-9rmv](https://github.com/sparklemotion/nekohtml/security/advisories/GHSA-9849-p7jc-9rmv)

## Which versions are affected by GHSA-gx8x-g87m-h5q6?

2 open source packages ship an affected version, including nokogiri.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.13.4 |
| `nokogiri` | RubyGems | All versions | 1.13.4 |

## How do I fix GHSA-gx8x-g87m-h5q6?

Upgrade nokogiri to 1.13.4 or later.

## Is GHSA-gx8x-g87m-h5q6 being exploited?

There is no known exploitation of GHSA-gx8x-g87m-h5q6 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-gx8x-g87m-h5q6 and fix it if it is affected.

What it is: GHSA-gx8x-g87m-h5q6 is a denial of service vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-gx8x-g87m-h5q6 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.13.4
- nokogiri (RubyGems): affected all versions; fixed in 1.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-gx8x-g87m-h5q6/ (Markdown: https://insights.sbomify.com/GHSA-gx8x-g87m-h5q6/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-gx8x-g87m-h5q6

---
From sbomify Insights: https://insights.sbomify.com/GHSA-gx8x-g87m-h5q6/
Summaries are generated and may contain mistakes; the official description above is the record.
