GHSA-h4gh-qq45-vh27 pyca/cryptography has a vulnerable OpenSSL included in cryptography wheels
Attackers can exploit vulnerable OpenSSL bundled in cryptography wheels to execute code or read data; users must upgrade the library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-h4gh-qq45-vh27?
GHSA-h4gh-qq45-vh27 is a vulnerability in cryptography, published on 3 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 37.0.0-43.0.0 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20240903.txt.
If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Which versions are affected by GHSA-h4gh-qq45-vh27?
2 open source packages ship an affected version, including cryptography.
| Package | Affected | Fixed in |
|---|---|---|
cryptography PyPI | From 37.0.0 | 43.0.1 |
cryptography PyPI | From 37.0.0 | 43.0.1 |
How do I fix GHSA-h4gh-qq45-vh27?
Upgrade cryptography to 43.0.1 or later.
Is GHSA-h4gh-qq45-vh27 being exploited?
There is no known exploitation of GHSA-h4gh-qq45-vh27 in the wild and no public exploit code.