# GHSA-h4gh-qq45-vh27: pyca/cryptography has a vulnerable OpenSSL included in cryptography wheels

> Attackers can exploit vulnerable OpenSSL bundled in cryptography wheels to execute code or read data; users must upgrade the library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2024

## What is GHSA-h4gh-qq45-vh27?

GHSA-h4gh-qq45-vh27 is a vulnerability in cryptography, published on 3 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 37.0.0-43.0.0 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20240903.txt.

If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

## Which versions are affected by GHSA-h4gh-qq45-vh27?

2 open source packages ship an affected version, including cryptography.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cryptography` | PyPI | From 37.0.0 | 43.0.1 |
| `cryptography` | PyPI | From 37.0.0 | 43.0.1 |

## How do I fix GHSA-h4gh-qq45-vh27?

Upgrade cryptography to 43.0.1 or later.

## Is GHSA-h4gh-qq45-vh27 being exploited?

There is no known exploitation of GHSA-h4gh-qq45-vh27 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-h4gh-qq45-vh27 and fix it if it is affected.

What it is: GHSA-h4gh-qq45-vh27 is a vulnerability in cryptography, published on 3 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-h4gh-qq45-vh27 in the wild and no public exploit code.

Affected packages and fixed versions:
- cryptography (PyPI): affected from 37.0.0; fixed in 43.0.1
- cryptography (PyPI): affected from 37.0.0; fixed in 43.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-h4gh-qq45-vh27/ (Markdown: https://insights.sbomify.com/GHSA-h4gh-qq45-vh27/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-h4gh-qq45-vh27

---
From sbomify Insights: https://insights.sbomify.com/GHSA-h4gh-qq45-vh27/
Summaries are generated and may contain mistakes; the official description above is the record.
