{"answers":{"affected":"3 open source packages ship an affected version, including arrow.","exploited":"There is no known exploitation of GHSA-h588-76vg-prgj in the wild and no public exploit code.","fix":"Upgrade arrow to 6.4.0 or later.","what":"GHSA-h588-76vg-prgj is a memory corruption vulnerability in arrow, published on 14 Sep 2021."},"fix_prompt":"Check this codebase for GHSA-h588-76vg-prgj and fix it if it is affected.\n\nWhat it is: GHSA-h588-76vg-prgj is a memory corruption vulnerability in arrow, published on 14 Sep 2021. \nExploitation: There is no known exploitation of GHSA-h588-76vg-prgj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- arrow (crates.io): affected all versions; fixed in 6.4.0\n- arrow (crates.io): affected all versions; fixed in 6.4.0\n- arrow (crates.io): affected from 0.0.0-0; fixed in 6.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-h588-76vg-prgj/ (Markdown: https://insights.sbomify.com/GHSA-h588-76vg-prgj/index.md)","id":"GHSA-h588-76vg-prgj","markdown":"https://insights.sbomify.com/GHSA-h588-76vg-prgj/index.md","name":"GHSA-h588-76vg-prgj","record":{"aliases":["RUSTSEC-2021-0117"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"unknown","non_default_config":false,"product_category":"Rust decimal library","requires_auth":"none","summary":"Attackers can trigger out-of-bounds reads in safe code via malformed buffers, potentially leaking memory or causing crashes in applications using this Rust library.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"`DecimalArray` performs insufficient bounds checks, which allows out-of-bounds reads in safe code if the lenght of the backing buffer is not a multiple of 16.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"`DecimalArray` does not perform bound checks on accessing values and offsets","id":"GHSA-h588-76vg-prgj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2021"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"arrow","purl":null,"source":"GHSA-h588-76vg-prgj"},{"ecosystem":"crates.io","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"arrow","purl":"pkg:cargo/arrow","source":"GHSA-h588-76vg-prgj"},{"ecosystem":"crates.io","fixed":["6.4.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"arrow","purl":"pkg:cargo/arrow","source":"RUSTSEC-2021-0117"}],"products":null,"published":"2021-09-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can trigger out-of-bounds reads in safe code via malformed buffers, potentially leaking memory or causing crashes in applications using this Rust library.","url":"https://insights.sbomify.com/GHSA-h588-76vg-prgj/"}