{"answers":{"affected":"2 open source packages ship an affected version, including adodb/adodb-php.","exploited":"There is no known exploitation of GHSA-h63c-xvpf-264j in the wild and no public exploit code.","fix":"Upgrade adodb/adodb-php to 5.20.11 or later.","what":"GHSA-h63c-xvpf-264j is a SQL injection vulnerability in adodb/adodb-php, published on 15 May 2024. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-h63c-xvpf-264j and fix it if it is affected.\n\nWhat it is: GHSA-h63c-xvpf-264j is a SQL injection vulnerability in adodb/adodb-php, published on 15 May 2024. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-h63c-xvpf-264j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- adodb/adodb-php (Packagist): affected all versions; fixed in 5.20.11\n- adodb/adodb-php (Packagist): affected all versions; fixed in 5.20.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-h63c-xvpf-264j/ (Markdown: https://insights.sbomify.com/GHSA-h63c-xvpf-264j/index.md)","id":"GHSA-h63c-xvpf-264j","markdown":"https://insights.sbomify.com/GHSA-h63c-xvpf-264j/index.md","name":"GHSA-h63c-xvpf-264j","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP database library","requires_auth":"unknown","summary":"An SQL injection vulnerability in the ADOdb PHP library allows attackers to manipulate database queries, potentially leading to unauthorized data access or modification.","user_interaction":"unknown","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The ADOdb Library for PHP prior to version 5.20.11 is prone to SQL Injection vulnerability in multiple drivers.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ADOdb SQL injection vulnerability","id":"GHSA-h63c-xvpf-264j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.20.11"],"introduced":["0"],"last_affected":[],"package":"adodb/adodb-php","purl":null,"source":"GHSA-h63c-xvpf-264j"},{"ecosystem":"Packagist","fixed":["5.20.11"],"introduced":["0"],"last_affected":[],"package":"adodb/adodb-php","purl":"pkg:composer/adodb/adodb-php","source":"GHSA-h63c-xvpf-264j"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An SQL injection vulnerability in the ADOdb PHP library allows attackers to manipulate database queries, potentially leading to unauthorized data access or modification.","url":"https://insights.sbomify.com/GHSA-h63c-xvpf-264j/"}