{"answers":{"affected":"2 open source packages ship an affected version, including diff.","exploited":"There is no known exploitation of GHSA-h6ch-v84p-w6p9 in the wild and no public exploit code.","fix":"Upgrade diff to 3.5.0 or later.","what":"GHSA-h6ch-v84p-w6p9 is a denial of service vulnerability in diff, published on 13 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-h6ch-v84p-w6p9 and fix it if it is affected.\n\nWhat it is: GHSA-h6ch-v84p-w6p9 is a denial of service vulnerability in diff, published on 13 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-h6ch-v84p-w6p9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- diff (npm): affected all versions; fixed in 3.5.0\n- diff (npm): affected all versions; fixed in 3.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-h6ch-v84p-w6p9/ (Markdown: https://insights.sbomify.com/GHSA-h6ch-v84p-w6p9/index.md)","id":"GHSA-h6ch-v84p-w6p9","markdown":"https://insights.sbomify.com/GHSA-h6ch-v84p-w6p9/index.md","name":"GHSA-h6ch-v84p-w6p9","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript diff library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the diff library by providing specially crafted input that triggers excessive regex processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A vulnerability was found in diff before v3.5.0, the affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"GHSA-h6ch-v84p-w6p9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"diff","purl":null,"source":"GHSA-h6ch-v84p-w6p9"},{"ecosystem":"npm","fixed":["3.5.0"],"introduced":["0"],"last_affected":[],"package":"diff","purl":"pkg:npm/diff","source":"GHSA-h6ch-v84p-w6p9"}],"products":null,"published":"2019-06-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service in applications using the diff library by providing specially crafted input that triggers excessive regex processing.","url":"https://insights.sbomify.com/GHSA-h6ch-v84p-w6p9/"}