GHSA-h87q-g2wp-47pj Signatures are mistakenly recognized to be valid in jsrsasign
Not scored
Published
Check this codebase for GHSA-h87q-g2wp-47pj and fix it if it is affected.
What it is: GHSA-h87q-g2wp-47pj is a vulnerability in jsrsasign, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-h87q-g2wp-47pj in the wild and no public exploit code.
Affected packages and fixed versions:
- jsrsasign (npm): affected all versions; fixed in 10.2.0
- jsrsasign (npm): affected all versions; fixed in 10.2.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/GHSA-h87q-g2wp-47pj/ (Markdown: https://insights.sbomify.com/GHSA-h87q-g2wp-47pj/index.md)
The jsrsasign library incorrectly validates certain invalid RSA signatures, potentially allowing attackers to bypass signature verification checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-h87q-g2wp-47pj?
GHSA-h87q-g2wp-47pj is a vulnerability in jsrsasign, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In the jsrsasign package through 10.1.13 for Node.js, some invalid RSA PKCS#1 v1.5 signatures are mistakenly recognized to be valid. NOTE: there is no known practical attack.
Which versions are affected by GHSA-h87q-g2wp-47pj?
2 open source packages ship an affected version, including jsrsasign.
| Package | Affected | Fixed in |
|---|---|---|
jsrsasign npm | All versions | 10.2.0 |
jsrsasign npm | All versions | 10.2.0 |
How do I fix GHSA-h87q-g2wp-47pj?
Upgrade jsrsasign to 10.2.0 or later.
Is GHSA-h87q-g2wp-47pj being exploited?
There is no known exploitation of GHSA-h87q-g2wp-47pj in the wild and no public exploit code.