{"answers":{"affected":"2 open source packages ship an affected version, including jsrsasign.","exploited":"There is no known exploitation of GHSA-h87q-g2wp-47pj in the wild and no public exploit code.","fix":"Upgrade jsrsasign to 10.2.0 or later.","what":"GHSA-h87q-g2wp-47pj is a vulnerability in jsrsasign, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-h87q-g2wp-47pj and fix it if it is affected.\n\nWhat it is: GHSA-h87q-g2wp-47pj is a vulnerability in jsrsasign, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-h87q-g2wp-47pj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jsrsasign (npm): affected all versions; fixed in 10.2.0\n- jsrsasign (npm): affected all versions; fixed in 10.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-h87q-g2wp-47pj/ (Markdown: https://insights.sbomify.com/GHSA-h87q-g2wp-47pj/index.md)","id":"GHSA-h87q-g2wp-47pj","markdown":"https://insights.sbomify.com/GHSA-h87q-g2wp-47pj/index.md","name":"GHSA-h87q-g2wp-47pj","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript crypto library","requires_auth":"none","summary":"The jsrsasign library incorrectly validates certain invalid RSA signatures, potentially allowing attackers to bypass signature verification checks.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"In the jsrsasign package through 10.1.13 for Node.js, some invalid RSA PKCS#1 v1.5 signatures are mistakenly recognized to be valid. NOTE: there is no known practical attack.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Signatures are mistakenly recognized to be valid in jsrsasign","id":"GHSA-h87q-g2wp-47pj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["10.2.0"],"introduced":["0"],"last_affected":[],"package":"jsrsasign","purl":null,"source":"GHSA-h87q-g2wp-47pj"},{"ecosystem":"npm","fixed":["10.2.0"],"introduced":["0"],"last_affected":[],"package":"jsrsasign","purl":"pkg:npm/jsrsasign","source":"GHSA-h87q-g2wp-47pj"}],"products":null,"published":"2022-02-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The jsrsasign library incorrectly validates certain invalid RSA signatures, potentially allowing attackers to bypass signature verification checks.","url":"https://insights.sbomify.com/GHSA-h87q-g2wp-47pj/"}