{"answers":{"affected":"2 open source packages ship an affected version, including tinymce.","exploited":"There is no known exploitation of GHSA-h96f-fc7c-9r55 in the wild and no public exploit code.","fix":"Upgrade tinymce to 5.6.0 or later.","what":"GHSA-h96f-fc7c-9r55 is a denial of service vulnerability in tinymce, published on 6 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-h96f-fc7c-9r55 and fix it if it is affected.\n\nWhat it is: GHSA-h96f-fc7c-9r55 is a denial of service vulnerability in tinymce, published on 6 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-h96f-fc7c-9r55 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tinymce (npm): affected all versions; fixed in 5.6.0\n- tinymce (npm): affected all versions; fixed in 5.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-h96f-fc7c-9r55/ (Markdown: https://insights.sbomify.com/GHSA-h96f-fc7c-9r55/index.md)","id":"GHSA-h96f-fc7c-9r55","markdown":"https://insights.sbomify.com/GHSA-h96f-fc7c-9r55/index.md","name":"GHSA-h96f-fc7c-9r55","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"TinyMCE plugin","requires_auth":"none","summary":"A regex denial of service in the codesample plugin allows attackers to lock up browsers via malformed Ruby code samples, affecting TinyMCE users.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nA regex denial of service (ReDoS) vulnerability was discovered in a dependency of the `codesample` plugin. The vulnerability allowed poorly formed ruby code samples to lock up the browser while performing syntax highlighting. This impacts users of the `codesample` plugin using TinyMCE 5.5.1 or lower.\n\n### Patches\nThis vulnerability has been patched in TinyMCE 5.6.0 by upgrading to a version of the dependency without the vulnerability.\n\n### Workarounds\nTo work around this vulnerability, either:\n- Upgrade to TinyMCE 5.6.0 or higher\n- Disable the `codesample` plugin\n- Disable ruby code samples using the [codesample_languages](https://www.tiny.cloud/docs/plugins/opensource/codesample/#exampleusingcodesample_languages) setting\n- Override the PrismJS syntax highlighter to version 1.21.0 or higher using the [codesample_global_prismjs](https://www.tiny.cloud/docs/plugins/opensource/codesample/#codesample_global_prismjs) setting\n\n### Acknowledgements\nTiny Technologies would like to thank Erik Krogh Kristensen at GitHub for discovering this vulnerability.\n\n### References\nhttps://www.tiny.cloud/docs/release-notes/release-notes56/#securityfixes\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in the [TinyMCE repo](http://github.com/tinymce/tinymce/issues)\n* Email us at [infosec@tiny.cloud](mailto:infosec@tiny.cloud)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Regex denial of service vulnerability in codesample plugin","id":"GHSA-h96f-fc7c-9r55","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["5.6.0"],"introduced":["0"],"last_affected":[],"package":"tinymce","purl":null,"source":"GHSA-h96f-fc7c-9r55"},{"ecosystem":"npm","fixed":["5.6.0"],"introduced":["0"],"last_affected":[],"package":"tinymce","purl":"pkg:npm/tinymce","source":"GHSA-h96f-fc7c-9r55"}],"products":null,"published":"2021-01-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A regex denial of service in the codesample plugin allows attackers to lock up browsers via malformed Ruby code samples, affecting TinyMCE users.","url":"https://insights.sbomify.com/GHSA-h96f-fc7c-9r55/"}