{"answers":{"affected":"2 open source packages ship an affected version, including apostrophe.","exploited":"There is no known exploitation of GHSA-h97g-4mx7-5p2p in the wild and no public exploit code.","fix":"Upgrade apostrophe to 2.92.0 or later.","what":"GHSA-h97g-4mx7-5p2p is a vulnerability in apostrophe, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-h97g-4mx7-5p2p and fix it if it is affected.\n\nWhat it is: GHSA-h97g-4mx7-5p2p is a vulnerability in apostrophe, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-h97g-4mx7-5p2p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apostrophe (npm): affected all versions; fixed in 2.92.0\n- apostrophe (npm): affected all versions; fixed in 2.92.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-h97g-4mx7-5p2p/ (Markdown: https://insights.sbomify.com/GHSA-h97g-4mx7-5p2p/index.md)","id":"GHSA-h97g-4mx7-5p2p","markdown":"https://insights.sbomify.com/GHSA-h97g-4mx7-5p2p/index.md","name":"GHSA-h97g-4mx7-5p2p","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apostrophe CMS","requires_auth":"none","summary":"An open redirect vulnerability allows attackers to redirect users to malicious third-party websites via crafted URLs.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `apostrophe` prior to 2.92.0 are vulnerable to Open Redirect. The package redirected requests to third-party websites if escaped URLs followed by a trailing `/` were appended at the end.\n\n## Recommendation\n\nUpdate to version 2.92.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Open Redirect in apostrophe","id":"GHSA-h97g-4mx7-5p2p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"open_redirect","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.92.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-h97g-4mx7-5p2p"},{"ecosystem":"npm","fixed":["2.92.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-h97g-4mx7-5p2p"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An open redirect vulnerability allows attackers to redirect users to malicious third-party websites via crafted URLs.","url":"https://insights.sbomify.com/GHSA-h97g-4mx7-5p2p/"}