{"answers":{"affected":"2 open source packages ship an affected version, including @vendure/core.","exploited":"There is no known exploitation of GHSA-h9wq-xcqx-mqxm in the wild and no public exploit code.","fix":"Upgrade @vendure/core to 2.0.3 or later.","what":"GHSA-h9wq-xcqx-mqxm is a vulnerability in @vendure/core, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-h9wq-xcqx-mqxm and fix it if it is affected.\n\nWhat it is: GHSA-h9wq-xcqx-mqxm is a vulnerability in @vendure/core, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-h9wq-xcqx-mqxm in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @vendure/core (npm): affected all versions; fixed in 2.0.3\n- @vendure/core (npm): affected all versions; fixed in 2.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-h9wq-xcqx-mqxm/ (Markdown: https://insights.sbomify.com/GHSA-h9wq-xcqx-mqxm/index.md)","id":"GHSA-h9wq-xcqx-mqxm","markdown":"https://insights.sbomify.com/GHSA-h9wq-xcqx-mqxm/index.md","name":"GHSA-h9wq-xcqx-mqxm","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"configuration_change","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Vendure e-commerce framework","requires_auth":"none","summary":"Insecure default cookie settings in Vendure allow Cross-Site Request Forgery attacks against all API requests, requiring manual configuration changes to mitigate.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nVendure is an e-commerce GraphQL framework with a number of APIs and different levels of\nauthorization. By default the Cookie settings are insecure, having the SameSite setting as false\nwhich results in not having one (originates from the cookie-session npm package’s default\nsettings).\n\n### Patches\nIn progress\n\n### Workarounds\nManually set the `authOptions.cookieOptions.sameSite` configuration option to `'strict'`, `'lax'` or `true`.\n\n### References\n_Are there any links users can visit to find out more?_","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Vendure Cross Site Request Forgery vulnerability impacting all API requests","id":"GHSA-h9wq-xcqx-mqxm","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"@vendure/core","purl":null,"source":"GHSA-h9wq-xcqx-mqxm"},{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"@vendure/core","purl":"pkg:npm/%40vendure/core","source":"GHSA-h9wq-xcqx-mqxm"}],"products":null,"published":"2023-07-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Insecure default cookie settings in Vendure allow Cross-Site Request Forgery attacks against all API requests, requiring manual configuration changes to mitigate.","url":"https://insights.sbomify.com/GHSA-h9wq-xcqx-mqxm/"}