{"answers":{"affected":"3 open source packages ship an affected version, including libcrux-chacha20poly1305.","exploited":"There is no known exploitation of GHSA-hc3c-63hc-2r9f in the wild and no public exploit code.","fix":"Upgrade libcrux-chacha20poly1305 to 0.0.8 or later.","what":"GHSA-hc3c-63hc-2r9f is a denial of service vulnerability in libcrux-chacha20poly1305, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-hc3c-63hc-2r9f and fix it if it is affected.\n\nWhat it is: GHSA-hc3c-63hc-2r9f is a denial of service vulnerability in libcrux-chacha20poly1305, published on 29 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-hc3c-63hc-2r9f in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libcrux-chacha20poly1305 (crates.io): affected all versions; fixed in 0.0.8\n- libcrux-chacha20poly1305 (crates.io): affected all versions; fixed in 0.0.8\n- libcrux-chacha20poly1305 (crates.io): affected from 0.0.0-0; fixed in 0.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hc3c-63hc-2r9f/ (Markdown: https://insights.sbomify.com/GHSA-hc3c-63hc-2r9f/index.md)","id":"GHSA-hc3c-63hc-2r9f","markdown":"https://insights.sbomify.com/GHSA-hc3c-63hc-2r9f/index.md","name":"GHSA-hc3c-63hc-2r9f","record":{"aliases":["RUSTSEC-2026-0124"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust crypto library","requires_auth":"none","summary":"An attacker can cause a denial of service by providing an overlong ciphertext buffer to the libcrux encryption functions, crashing the application.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"An application that passes in a ciphertext buffer of length greater\nthan `ptxt.len() + TAG_LEN` to `libcrux_chacha20poly1305::encrypt` or\n`libcrux_chacha20poly1305::xchacha20_poly1305::encrypt` would\nexperience a panic.\n\n## Impact\nAn application where the length of the ciphertext buffer is under\nattacker control could be made to crash.\n\n## Mitigation\nThe fix makes it so that `libcrux_chacha20poly1305::encrypt` and\n`libcrux_chacha20poly1305::xchacha20_poly1305::encrypt` no longer\npanic in this case, but instead write out the ciphertext and tag into\nthe first `ptxt.len() + TAG_LEN` bytes of the provided buffer.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Potential Panic on Overlong Ciphertext Buffer","id":"GHSA-hc3c-63hc-2r9f","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.0.8"],"introduced":["0"],"last_affected":[],"package":"libcrux-chacha20poly1305","purl":null,"source":"GHSA-hc3c-63hc-2r9f"},{"ecosystem":"crates.io","fixed":["0.0.8"],"introduced":["0"],"last_affected":[],"package":"libcrux-chacha20poly1305","purl":"pkg:cargo/libcrux-chacha20poly1305","source":"GHSA-hc3c-63hc-2r9f"},{"ecosystem":"crates.io","fixed":["0.0.8"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libcrux-chacha20poly1305","purl":"pkg:cargo/libcrux-chacha20poly1305","source":"RUSTSEC-2026-0124"}],"products":null,"published":"2026-03-29","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service by providing an overlong ciphertext buffer to the libcrux encryption functions, crashing the application.","url":"https://insights.sbomify.com/GHSA-hc3c-63hc-2r9f/"}