{"answers":{"affected":"2 open source packages ship an affected version, including ezsystems/ezplatform-user.","exploited":"There is no known exploitation of GHSA-hfpp-2vhw-qq43 in the wild and no public exploit code.","fix":"Upgrade ezsystems/ezplatform-user to 1.0.1 or later.","what":"GHSA-hfpp-2vhw-qq43 is an authentication bypass vulnerability in ezsystems/ezplatform-user, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-hfpp-2vhw-qq43 and fix it if it is affected.\n\nWhat it is: GHSA-hfpp-2vhw-qq43 is an authentication bypass vulnerability in ezsystems/ezplatform-user, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-hfpp-2vhw-qq43 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/ezplatform-user (Packagist): affected from 1.0.0; fixed in 1.0.1\n- ezsystems/ezplatform-user (Packagist): affected from 1.0.0; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hfpp-2vhw-qq43/ (Markdown: https://insights.sbomify.com/GHSA-hfpp-2vhw-qq43/index.md)","id":"GHSA-hfpp-2vhw-qq43","markdown":"https://insights.sbomify.com/GHSA-hfpp-2vhw-qq43/index.md","name":"GHSA-hfpp-2vhw-qq43","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"eZ Platform Admin UI","requires_auth":"none","summary":"Attackers can brute force password reset tokens to take over user accounts in eZ Platform Admin UI.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"his Security Update fixes a severe vulnerability in the eZ Platform Admin UI, and we recommend that you install it as soon as possible. It affects eZ Platform 2.x.\n \nThe functionality for resetting a forgotten password is vulnerable to brute force attack. Depending on configuration and other circumstances an attacker may exploit this to gain control over user accounts. The update ensures such an attack is exceedingly unlikely to succeed.\n \nYou may want to consider a configuration change to further strengthen your security. By default a password reset request is valid for 1 hour. Reducing this time will make attacks even more difficult, but ensure there is enough time left to account for email delivery delays, and user delays. See documentation at https://doc.ezplatform.com/en/latest/guide/user_management/#changing-and-recovering-passwords\n\nTo install, use Composer to update to one of the \"Resolving versions\" mentioned above. If you use eZ Platform 2.5, update ezsystems/ezplatform-user to v1.0.1. If you use eZ Platform 2.4, update ezsystems/ezplatform-admin-ui to v1.4.6, and ezsystems/ezplatform-admin-ui-modules to v1.4.4, and ezsystems/repository-forms to v2.4.5)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"eZ Platform Admin UI Password reset vulnerability","id":"GHSA-hfpp-2vhw-qq43","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"ezsystems/ezplatform-user","purl":null,"source":"GHSA-hfpp-2vhw-qq43"},{"ecosystem":"Packagist","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"ezsystems/ezplatform-user","purl":"pkg:composer/ezsystems/ezplatform-user","source":"GHSA-hfpp-2vhw-qq43"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can brute force password reset tokens to take over user accounts in eZ Platform Admin UI.","url":"https://insights.sbomify.com/GHSA-hfpp-2vhw-qq43/"}