{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework1.","exploited":"There is no known exploitation of GHSA-hg35-vqp3-fv39 in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework1 to 1.9.7 or later.","what":"GHSA-hg35-vqp3-fv39 is a cross-site scripting vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-hg35-vqp3-fv39 and fix it if it is affected.\n\nWhat it is: GHSA-hg35-vqp3-fv39 is a cross-site scripting vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-hg35-vqp3-fv39 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework1 (Packagist): affected from 1.9.0; fixed in 1.9.7\n- zendframework/zendframework1 (Packagist): affected from 1.9.0; fixed in 1.9.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hg35-vqp3-fv39/ (Markdown: https://insights.sbomify.com/GHSA-hg35-vqp3-fv39/index.md)","id":"GHSA-hg35-vqp3-fv39","markdown":"https://insights.sbomify.com/GHSA-hg35-vqp3-fv39/index.md","name":"GHSA-hg35-vqp3-fv39","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"Inconsistent encoding handling in Zend Framework components may allow XSS attacks if non-standard character sets are used or defined by users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A number of classes, primarily within the `Zend_Form`, `Zend_Filter`, `Zend_Form`, `Zend_Log` and `Zend_View components`, contained character encoding inconsistencies whereby calls to the `htmlspecialchars()` and htmlentities() functions used undefined or hard coded charset parameters. In many of these cases developers were unable to set a character encoding of their choice. These inconsistencies could, in specific circumstances, allow certain multibyte representations of special HTML characters pass through unescaped leaving applications potentially vulnerable to cross-site scripting (XSS) exploits. Such exploits would only be possible if a developer used a non-typical character encoding (such as UTF-7), allowed users to define the character encoding, or served HTML documents without a valid character set defined.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendFramework potential Cross-site Scripting vectors due to inconsistent encodings","id":"GHSA-hg35-vqp3-fv39","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.9.7"],"introduced":["1.9.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-hg35-vqp3-fv39"},{"ecosystem":"Packagist","fixed":["1.9.7"],"introduced":["1.9.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-hg35-vqp3-fv39"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Inconsistent encoding handling in Zend Framework components may allow XSS attacks if non-standard character sets are used or defined by users.","url":"https://insights.sbomify.com/GHSA-hg35-vqp3-fv39/"}