GHSA-hg58-rf2h-6rr7 CometBFT is unstability during blocksync when syncing from malicious peer
A malicious peer can cause CometBFT nodes to panic or get stuck during blocksync, resulting in a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-hg58-rf2h-6rr7?
GHSA-hg58-rf2h-6rr7 is a denial of service vulnerability in github.com/cometbft/cometbft, published on 28 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Name: ASA-2024-008: Instability during blocksync when syncing from malicious peer Component: CometBFT Criticality: Medium (ACMv1: I:Moderate; L: Possible) Affected versions: < v0.38.7
Summary
An issue was identified for nodes syncing on an existing network during blocksync in which a malicious peer could cause the syncing peer to panic, enter into a catastrophic invalid syncing state or get stuck in blocksync mode, never switching to consensus. It is recommended for all clients to adopt this patch so that blocksync functions as expected and is tolerant of malicious peers presenting invalid data in this situation. Nodes that are vulnerable to this state may experience a Denial of Service condition in which syncing will not work as expected when joining a network as a client.
Recognition
This issue was reported to the Cosmos Bug Bounty Program on HackerOne on 5/01/24 by unknown_feature. If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see https://hackerone.com/cosmos.
If you have questions about Interchain security efforts, please reach out to our official communication channel at [email protected].
For more information about CometBFT, please see https://docs.cometbft.com/.
For more information about the Interchain Foundation’s engagement with Amulet, please see https://github.com/interchainio/security.
Which versions are affected by GHSA-hg58-rf2h-6rr7?
5 open source packages ship an affected version, including github.com/cometbft/cometbft.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cometbft/cometbft Go | From 0.37.0 | 0.37.7, 0.38.8 |
github.com/cometbft/cometbft Go | From 0.37.0 | 0.37.7 |
github.com/cometbft/cometbft Go | From 0.37.0 | 0.37.7 |
github.com/cometbft/cometbft Go | From 0.38.0 | 0.38.8 |
github.com/cometbft/cometbft Go | From 0.38.0 | 0.38.8 |
How do I fix GHSA-hg58-rf2h-6rr7?
Upgrade github.com/cometbft/cometbft to a fixed version for your release line: 0.37.7 or 0.38.8.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is GHSA-hg58-rf2h-6rr7 being exploited?
There is no known exploitation of GHSA-hg58-rf2h-6rr7 in the wild and no public exploit code.
Sources
Also known as GO-2024-2951.