{"answers":{"affected":"2 open source packages ship an affected version, including mirador.","exploited":"There is no known exploitation of GHSA-hgwm-pv9h-q5m7 in the wild and no public exploit code.","fix":"Upgrade mirador to 3.0.0-alpha.0 or later.","what":"GHSA-hgwm-pv9h-q5m7 is a cross-site scripting vulnerability in mirador, published on 18 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-hgwm-pv9h-q5m7 and fix it if it is affected.\n\nWhat it is: GHSA-hgwm-pv9h-q5m7 is a cross-site scripting vulnerability in mirador, published on 18 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-hgwm-pv9h-q5m7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mirador (npm): affected all versions; fixed in 3.0.0-alpha.0\n- mirador (npm): affected all versions; fixed in 3.0.0-alpha.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hgwm-pv9h-q5m7/ (Markdown: https://insights.sbomify.com/GHSA-hgwm-pv9h-q5m7/index.md)","id":"GHSA-hgwm-pv9h-q5m7","markdown":"https://insights.sbomify.com/GHSA-hgwm-pv9h-q5m7/index.md","name":"GHSA-hgwm-pv9h-q5m7","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Mirador viewer","requires_auth":"none","summary":"An XSS vulnerability in the jQuery dependency of Mirador allows attackers to execute arbitrary scripts in the context of the viewer.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nMirador users less than v3.0.0 (alpha-rc) versions that have an unpatched jQuery. When adopters update jQuery they will find some of Mirador functionality to be broken.\n\n### Patches\nMirador adopters should update to v3.0.0, no updates exist for v2.x releases.\n\n### Workarounds\nYes, Mirador users could fork and create their own custom build of Mirador and make the bug fixes themselves.\n\n### References\nhttps://github.com/advisories/GHSA-gxr4-xjj5-5px2\nhttps://github.com/advisories/GHSA-jpcq-cgw6-v4j6\n\nhttps://blog.jquery.com/2020/04/10/jquery-3-5-0-released/\nhttps://jquery.com/upgrade-guide/3.5/","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Potential XSS in jQuery dependency in Mirador","id":"GHSA-hgwm-pv9h-q5m7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["3.0.0-alpha.0"],"introduced":["0"],"last_affected":[],"package":"mirador","purl":null,"source":"GHSA-hgwm-pv9h-q5m7"},{"ecosystem":"npm","fixed":["3.0.0-alpha.0"],"introduced":["0"],"last_affected":[],"package":"mirador","purl":"pkg:npm/mirador","source":"GHSA-hgwm-pv9h-q5m7"}],"products":null,"published":"2020-09-18","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An XSS vulnerability in the jQuery dependency of Mirador allows attackers to execute arbitrary scripts in the context of the viewer.","url":"https://insights.sbomify.com/GHSA-hgwm-pv9h-q5m7/"}