{"answers":{"affected":"2 open source packages ship an affected version, including socialiteproviders/steam.","exploited":"There is no known exploitation of GHSA-hhw9-35p2-q2c5 in the wild and no public exploit code.","fix":"Upgrade socialiteproviders/steam to 3.0 or later.","what":"GHSA-hhw9-35p2-q2c5 is an authentication bypass vulnerability in socialiteproviders/steam, published on 29 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-hhw9-35p2-q2c5 and fix it if it is affected.\n\nWhat it is: GHSA-hhw9-35p2-q2c5 is an authentication bypass vulnerability in socialiteproviders/steam, published on 29 Jan 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-hhw9-35p2-q2c5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- socialiteproviders/steam (Packagist): affected all versions; fixed in 3.0\n- socialiteproviders/steam (Packagist): affected all versions; fixed in 3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hhw9-35p2-q2c5/ (Markdown: https://insights.sbomify.com/GHSA-hhw9-35p2-q2c5/index.md)","id":"GHSA-hhw9-35p2-q2c5","markdown":"https://insights.sbomify.com/GHSA-hhw9-35p2-q2c5/index.md","name":"GHSA-hhw9-35p2-q2c5","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Socialite Provider","requires_auth":"none","summary":"Attackers can bypass Steam login validation by substituting a malicious OpenID server, potentially taking over user accounts.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThe outdated version 1 of the Steam Socialite Provider doesn't check properly if the login comes from `steamcommunity.com`, allowing a malicious actor to substitute their own openID server.\n\n### Patches\nThis vulnerability only affects the outdated v1.x versions of the package. These are no longer maintained, users should upgrade to v3 or v4, which use a hardcoded endpoint to verify the login.\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [SocialiteProviders/Providers](https://github.com/SocialiteProviders/Providers)\n* Email us at [socialite@atymic.dev](mailto:socialite@atymic.dev)","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Steam Socialite Provider v1 does not correctly validate openid server","id":"GHSA-hhw9-35p2-q2c5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"socialiteproviders/steam","purl":null,"source":"GHSA-hhw9-35p2-q2c5"},{"ecosystem":"Packagist","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"socialiteproviders/steam","purl":"pkg:composer/socialiteproviders/steam","source":"GHSA-hhw9-35p2-q2c5"}],"products":null,"published":"2021-01-29","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass Steam login validation by substituting a malicious OpenID server, potentially taking over user accounts.","url":"https://insights.sbomify.com/GHSA-hhw9-35p2-q2c5/"}