{"answers":{"affected":"2 open source packages ship an affected version, including litellm.","exploited":"There is no known exploitation of GHSA-hhww-mrg2-969h in the wild and no public exploit code.","fix":"Upgrade litellm to 1.85.0 or later.","what":"GHSA-hhww-mrg2-969h is a vulnerability in litellm, published on 27 Oct 2026."},"fix_prompt":"Check this codebase for GHSA-hhww-mrg2-969h and fix it if it is affected.\n\nWhat it is: GHSA-hhww-mrg2-969h is a vulnerability in litellm, published on 27 Oct 2026. \nExploitation: There is no known exploitation of GHSA-hhww-mrg2-969h in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected from 1.65.5; fixed in 1.85.0\n- litellm (PyPI): affected from 1.65.5; fixed in 1.85.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hhww-mrg2-969h/ (Markdown: https://insights.sbomify.com/GHSA-hhww-mrg2-969h/index.md)","id":"GHSA-hhww-mrg2-969h","markdown":"https://insights.sbomify.com/GHSA-hhww-mrg2-969h/index.md","name":"GHSA-hhww-mrg2-969h","record":{"aliases":[],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\n\nThe `/sso/debug/callback` endpoint reflected identity-provider-controlled fields into an inline `\u003cscript\u003e` block via `json.dumps`, which escapes JSON string syntax but not HTML context characters such as `\u003c/script\u003e`. An IdP-returned string field containing `\u003c/script\u003e` (for example a user-editable display name) closed the script block and executed attacker JavaScript in the proxy's origin.\n\n### Impact\n\nReflected XSS on the LiteLLM proxy origin. The route required no authentication, so an attacker with an account on the configured IdP whose claims pass such strings through verbatim could complete the SSO flow themselves and deliver the resulting callback URL to a logged-in proxy admin. Scripts executing in the proxy origin can read the dashboard session cookie and act with the victim's privileges, up to full admin account takeover.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"LiteLLM vulnerable to reflected XSS in /sso/debug/callback","id":"GHSA-hhww-mrg2-969h","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.85.0"],"introduced":["1.65.5"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-hhww-mrg2-969h"},{"ecosystem":"PyPI","fixed":["1.85.0"],"introduced":["1.65.5"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-hhww-mrg2-969h"}],"products":null,"published":"2026-10-27","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-hhww-mrg2-969h/"}