{"answers":{"affected":"2 open source packages ship an affected version, including auth0/login.","exploited":"There is no known exploitation of GHSA-hjfh-5jmm-xr24 in the wild and no public exploit code.","fix":"Upgrade auth0/login to 7.19.0 or later.","what":"GHSA-hjfh-5jmm-xr24 is a path traversal vulnerability in auth0/login, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-hjfh-5jmm-xr24 and fix it if it is affected.\n\nWhat it is: GHSA-hjfh-5jmm-xr24 is a path traversal vulnerability in auth0/login, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-hjfh-5jmm-xr24 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/login (Packagist): affected from 4.0.0; fixed in 7.19.0\n- auth0/login (Packagist): affected from 4.0.0; fixed in 7.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hjfh-5jmm-xr24/ (Markdown: https://insights.sbomify.com/GHSA-hjfh-5jmm-xr24/index.md)","id":"GHSA-hjfh-5jmm-xr24","markdown":"https://insights.sbomify.com/GHSA-hjfh-5jmm-xr24/index.md","name":"GHSA-hjfh-5jmm-xr24","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Auth0 Laravel SDK","requires_auth":"high_privilege","summary":"Attackers can exploit the Bulk User Import endpoint to access arbitrary files or URLs due to missing validation.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Overview\nIn applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs.\n\n### Am I affected?\nYou are affected by this vulnerability if you meet the following preconditions:\n1. Applications using the Auth0 laravel-auth0 SDK with version between 4.0.0 and 7.18.0,\n2. Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0.\n\n### Fix\nUpgrade Auth0 laravel-auth0 SDK to version 7.19.0 or greater.\n\n### Acknowledgement\nOkta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"laravel-auth0 SDK Does Not Properly Handle File Types in Bulk User Import","id":"GHSA-hjfh-5jmm-xr24","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["7.19.0"],"introduced":["4.0.0"],"last_affected":[],"package":"auth0/login","purl":null,"source":"GHSA-hjfh-5jmm-xr24"},{"ecosystem":"Packagist","fixed":["7.19.0"],"introduced":["4.0.0"],"last_affected":[],"package":"auth0/login","purl":"pkg:composer/auth0/login","source":"GHSA-hjfh-5jmm-xr24"}],"products":null,"published":"2025-10-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit the Bulk User Import endpoint to access arbitrary files or URLs due to missing validation.","url":"https://insights.sbomify.com/GHSA-hjfh-5jmm-xr24/"}