# GHSA-hjfh-5jmm-xr24: laravel-auth0 SDK Does Not Properly Handle File Types in Bulk User Import

> Attackers can exploit the Bulk User Import endpoint to access arbitrary files or URLs due to missing validation.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2025

## What is GHSA-hjfh-5jmm-xr24?

GHSA-hjfh-5jmm-xr24 is a path traversal vulnerability in auth0/login, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

### Overview
In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs.

### Am I affected?
You are affected by this vulnerability if you meet the following preconditions:
1. Applications using the Auth0 laravel-auth0 SDK with version between 4.0.0 and 7.18.0,
2. Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0.

### Fix
Upgrade Auth0 laravel-auth0 SDK to version 7.19.0 or greater.

### Acknowledgement
Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.

## Which versions are affected by GHSA-hjfh-5jmm-xr24?

2 open source packages ship an affected version, including auth0/login.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/login` | Packagist | From 4.0.0 | 7.19.0 |
| `auth0/login` | Packagist | From 4.0.0 | 7.19.0 |

## How do I fix GHSA-hjfh-5jmm-xr24?

Upgrade auth0/login to 7.19.0 or later.

## Is GHSA-hjfh-5jmm-xr24 being exploited?

There is no known exploitation of GHSA-hjfh-5jmm-xr24 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-hjfh-5jmm-xr24 and fix it if it is affected.

What it is: GHSA-hjfh-5jmm-xr24 is a path traversal vulnerability in auth0/login, published on 1 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-hjfh-5jmm-xr24 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/login (Packagist): affected from 4.0.0; fixed in 7.19.0
- auth0/login (Packagist): affected from 4.0.0; fixed in 7.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-hjfh-5jmm-xr24/ (Markdown: https://insights.sbomify.com/GHSA-hjfh-5jmm-xr24/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-hjfh-5jmm-xr24

---
From sbomify Insights: https://insights.sbomify.com/GHSA-hjfh-5jmm-xr24/
Summaries are generated and may contain mistakes; the official description above is the record.
