{"answers":{"affected":"3 open source packages ship an affected version, including uv.","exploited":"There is no known exploitation of GHSA-hq85-5cpj-mr62 in the wild and no public exploit code.","fix":"Upgrade uv to 0.13.4 or later.","what":"GHSA-hq85-5cpj-mr62 is a vulnerability in uv, published on 20 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-hq85-5cpj-mr62 and fix it if it is affected.\n\nWhat it is: GHSA-hq85-5cpj-mr62 is a vulnerability in uv, published on 20 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-hq85-5cpj-mr62 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uv (PyPI): affected all versions; fixed in 0.13.4\n- uv (PyPI): affected all versions; fixed in 0.13.4\n- uv (PyPI): affected all versions; fixed in 0.13.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hq85-5cpj-mr62/ (Markdown: https://insights.sbomify.com/GHSA-hq85-5cpj-mr62/index.md)","id":"GHSA-hq85-5cpj-mr62","markdown":"https://insights.sbomify.com/GHSA-hq85-5cpj-mr62/index.md","name":"GHSA-hq85-5cpj-mr62","record":{"aliases":["PYSEC-2026-4321"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python package manager","requires_auth":"none","summary":"Attackers with compromised CA keys can perform man-in-the-middle attacks against uv's default TLS verification, requiring an upgrade to remove the untrusted root.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"By default, uv verifies TLS connections against a vendored copy of the `webpki-root-certs` bundle. Versions before 0.13.4 include the `emSign ECC Root CA - G3` root. Eight eMudhra intermediate CA certificates that chain to that root have compromised private keys, and the CA has revoked them.\n\nAn attacker with one of the compromised keys can issue certificates that uv accepts for any hostname, and can be used to issue certificates to enable MITM attacks.\n\nuv 0.13.4 removes the root from its vendored bundle, following `webpki-root-certs` 1.0.10. Upgrade to 0.13.4 or later.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"uv's bundled CA store trusts an emSign root whose intermediate CA keys are compromised","id":"GHSA-hq85-5cpj-mr62","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.13.4"],"introduced":["0"],"last_affected":[],"package":"uv","purl":null,"source":"GHSA-hq85-5cpj-mr62"},{"ecosystem":"PyPI","fixed":["0.13.4"],"introduced":["0"],"last_affected":[],"package":"uv","purl":"pkg:pypi/uv","source":"GHSA-hq85-5cpj-mr62"},{"ecosystem":"PyPI","fixed":["0.13.4"],"introduced":["0"],"last_affected":[],"package":"uv","purl":"pkg:pypi/uv","source":"PYSEC-2026-4321"}],"products":null,"published":"2026-10-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers with compromised CA keys can perform man-in-the-middle attacks against uv's default TLS verification, requiring an upgrade to remove the untrusted root.","url":"https://insights.sbomify.com/GHSA-hq85-5cpj-mr62/"}