# GHSA-hw7r-qrhp-5pff: Unauthorized property update in CheckboxGroup component in Vaadin 12-14 and 15-20

> Attackers can modify disabled checkbox values in Vaadin CheckboxGroup components, bypassing intended UI restrictions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Aug 2021

## What is GHSA-hw7r-qrhp-5pff?

GHSA-hw7r-qrhp-5pff is a vulnerability in com.vaadin:vaadin-bom, published on 30 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper check in `CheckboxGroup` in `com.vaadin:vaadin-checkbox-flow` versions 1.2.0 prior to 2.0.0 (Vaadin 12.0.0 prior to 14.0.0), 2.0.0 prior to 3.0.0 (Vaadin 14.0.0 prior to 14.5.0), 3.0.0 through 4.0.1 (Vaadin 15.0.0 through 17.0.11), 14.5.0 through 14.6.7 (Vaadin 14.5.0 through 14.6.7), and 18.0.0 through 20.0.5 (Vaadin 18.0.0 through 20.0.5) allows attackers to modify the value of a disabled `Checkbox` inside enabled `CheckboxGroup` component via unspecified vectors.

- https://vaadin.com/security/cve-2021-33605

## Which versions are affected by GHSA-hw7r-qrhp-5pff?

4 open source packages ship an affected version, including com.vaadin:vaadin-bom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 12.0.0 | 14.6.8 |
| `com.vaadin:vaadin-bom` | Maven | From 12.0.0 | 14.6.8 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 20.0.6 |
| `com.vaadin:vaadin-bom` | Maven | From 15.0.0 | 20.0.6 |

## How do I fix GHSA-hw7r-qrhp-5pff?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 14.6.8 or 20.0.6.

## Is GHSA-hw7r-qrhp-5pff being exploited?

There is no known exploitation of GHSA-hw7r-qrhp-5pff in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-hw7r-qrhp-5pff and fix it if it is affected.

What it is: GHSA-hw7r-qrhp-5pff is a vulnerability in com.vaadin:vaadin-bom, published on 30 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-hw7r-qrhp-5pff in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 12.0.0; fixed in 14.6.8
- com.vaadin:vaadin-bom (Maven): affected from 12.0.0; fixed in 14.6.8
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 20.0.6
- com.vaadin:vaadin-bom (Maven): affected from 15.0.0; fixed in 20.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-hw7r-qrhp-5pff/ (Markdown: https://insights.sbomify.com/GHSA-hw7r-qrhp-5pff/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-hw7r-qrhp-5pff

---
From sbomify Insights: https://insights.sbomify.com/GHSA-hw7r-qrhp-5pff/
Summaries are generated and may contain mistakes; the official description above is the record.
