{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework1.","exploited":"There is no known exploitation of GHSA-hx3m-959f-v849 in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework1 to 1.7.5 or later.","what":"GHSA-hx3m-959f-v849 is a path traversal vulnerability in zendframework/zendframework1, published on 7 Jun 2024. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-hx3m-959f-v849 and fix it if it is affected.\n\nWhat it is: GHSA-hx3m-959f-v849 is a path traversal vulnerability in zendframework/zendframework1, published on 7 Jun 2024. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-hx3m-959f-v849 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework1 (Packagist): affected from 1.7.0; fixed in 1.7.5\n- zendframework/zendframework1 (Packagist): affected from 1.7.0; fixed in 1.7.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hx3m-959f-v849/ (Markdown: https://insights.sbomify.com/GHSA-hx3m-959f-v849/index.md)","id":"GHSA-hx3m-959f-v849","markdown":"https://insights.sbomify.com/GHSA-hx3m-959f-v849/index.md","name":"GHSA-hx3m-959f-v849","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"unknown","summary":"An attacker can read arbitrary system files by manipulating view script paths in Zend Framework, potentially exposing sensitive information.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Zend_View is a component that utilizes PHP as a templating language. To utilize it, you specify \"script paths\" that contain view scripts, and then `render()` view scripts by specifying subdirectories within those script paths; the output is then returned as a string value which may be cached or directly output.\n\n`Zend_View::setScriptPath()` in versions up to and including 1.7.4 include a potential Local File Inclusion vulnerability. If untrusted input is used to specify the script path and/or view script itself, a malicious attacker could potentially specify a system directory and thus render a system file.\n\nAs an example, if the user-supplied string `/etc/passwd` or a relative path that resolved to that file, was supplied to `Zend_View::render()`, that file would be rendered.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendFramework local file inclusion vector in `Zend_View::setScriptPath()` and `render()`","id":"GHSA-hx3m-959f-v849","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.7.5"],"introduced":["1.7.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-hx3m-959f-v849"},{"ecosystem":"Packagist","fixed":["1.7.5"],"introduced":["1.7.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-hx3m-959f-v849"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can read arbitrary system files by manipulating view script paths in Zend Framework, potentially exposing sensitive information.","url":"https://insights.sbomify.com/GHSA-hx3m-959f-v849/"}