{"answers":{"affected":"2 open source packages ship an affected version, including com.linecorp.centraldogma:centraldogma-server-auth-saml.","exploited":"There is no known exploitation of GHSA-hx5q-v6pj-533r in the wild and no public exploit code.","fix":"Upgrade com.linecorp.centraldogma:centraldogma-server-auth-saml to 0.64.3 or later.","what":"GHSA-hx5q-v6pj-533r is an authentication bypass vulnerability in com.linecorp.centraldogma:centraldogma-server-auth-saml, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-hx5q-v6pj-533r and fix it if it is affected.\n\nWhat it is: GHSA-hx5q-v6pj-533r is an authentication bypass vulnerability in com.linecorp.centraldogma:centraldogma-server-auth-saml, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-hx5q-v6pj-533r in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.linecorp.centraldogma:centraldogma-server-auth-saml (Maven): affected all versions; fixed in 0.64.3\n- com.linecorp.centraldogma:centraldogma-server-auth-saml (Maven): affected all versions; fixed in 0.64.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hx5q-v6pj-533r/ (Markdown: https://insights.sbomify.com/GHSA-hx5q-v6pj-533r/index.md)","id":"GHSA-hx5q-v6pj-533r","markdown":"https://insights.sbomify.com/GHSA-hx5q-v6pj-533r/index.md","name":"GHSA-hx5q-v6pj-533r","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Central Dogma server","requires_auth":"none","summary":"Attackers can bypass authentication by forging unsigned SAML messages in Central Dogma when SAML is enabled, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nWhen SAML is used as the authentication mechanism, Central Dogma accepts unsigned SAML messages (assertions, logout requests, etc.) as they are, rather than rejecting them by default. As a result, an attacker can forge a SAML message to authenticate themselves, despite the fact that such an unsigned SAML message should be rejected.\n\n### Patches\n\nThe vulnerability has been patched in Central Dogma 0.64.3 by updating its Armeria dependency to 1.27.2. All users who use SAML as the authentication mechanism must upgrade from 0.64.3 or later.\n\n### Workarounds\n\nA user can manually upgrade the `armeria-saml` module with the one from Armeria 1.27.2 or later, either by replacing the JAR in the Central Dogma distribution or by updating the dependency tree of the build.\n\n### References\n\n[`SamlMessageUtil.validateSignature()`](https://github.com/line/armeria/blob/0efc776988d71be4da6e506ec8a33c2b7b43f567/saml/src/main/java/com/linecorp/armeria/server/saml/SamlMessageUtil.java#L160-L163)","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"SAML authentication bypass due to missing validation on unsigned SAML messages","id":"GHSA-hx5q-v6pj-533r","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["0.64.3"],"introduced":["0"],"last_affected":[],"package":"com.linecorp.centraldogma:centraldogma-server-auth-saml","purl":null,"source":"GHSA-hx5q-v6pj-533r"},{"ecosystem":"Maven","fixed":["0.64.3"],"introduced":["0"],"last_affected":[],"package":"com.linecorp.centraldogma:centraldogma-server-auth-saml","purl":"pkg:maven/com.linecorp.centraldogma/centraldogma-server-auth-saml","source":"GHSA-hx5q-v6pj-533r"}],"products":null,"published":"2024-02-26","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass authentication by forging unsigned SAML messages in Central Dogma when SAML is enabled, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/GHSA-hx5q-v6pj-533r/"}