{"answers":{"affected":"4 open source packages ship an affected version, including eslint-config-eslint and eslint-scope.","exploited":"There is no known exploitation of GHSA-hxxf-q3w9-4xgw in the wild and no public exploit code.","fix":"Upgrade eslint-config-eslint to 6.0.0 or later.","what":"GHSA-hxxf-q3w9-4xgw is a vulnerability in eslint-config-eslint, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-hxxf-q3w9-4xgw and fix it if it is affected.\n\nWhat it is: GHSA-hxxf-q3w9-4xgw is a vulnerability in eslint-config-eslint, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-hxxf-q3w9-4xgw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eslint-config-eslint (npm): affected from 5.0.2; fixed in 6.0.0\n- eslint-config-eslint (npm): affected from 5.0.2; fixed in 6.0.0\n- eslint-scope (npm): affected from 3.7.2; fixed in 3.7.3\n- eslint-scope (npm): affected from 3.7.2; fixed in 3.7.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-hxxf-q3w9-4xgw/ (Markdown: https://insights.sbomify.com/GHSA-hxxf-q3w9-4xgw/index.md)","id":"GHSA-hxxf-q3w9-4xgw","markdown":"https://insights.sbomify.com/GHSA-hxxf-q3w9-4xgw/index.md","name":"GHSA-hxxf-q3w9-4xgw","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"npm package","requires_auth":"none","summary":"A malicious version of the eslint-scope npm package steals authentication tokens from .npmrc files, requiring immediate token revocation and package removal.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Version 3.7.2 of `eslint-scope` was published without authorization and was found to contain malicious code. This code would read the users `.npmrc` file and send any found authentication tokens to 2 remote servers.\n\n## Recommendation\n\nThe best course of action if you found this package installed in your environment is to revoke all your npm tokens. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/working_with_tokens#how-to-revoke-tokens","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Malicious Package in eslint-scope","id":"GHSA-hxxf-q3w9-4xgw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2018"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["6.0.0"],"introduced":["5.0.2"],"last_affected":[],"package":"eslint-config-eslint","purl":null,"source":"GHSA-hxxf-q3w9-4xgw"},{"ecosystem":"npm","fixed":["6.0.0"],"introduced":["5.0.2"],"last_affected":[],"package":"eslint-config-eslint","purl":"pkg:npm/eslint-config-eslint","source":"GHSA-hxxf-q3w9-4xgw"},{"ecosystem":"npm","fixed":["3.7.3"],"introduced":["3.7.2"],"last_affected":[],"package":"eslint-scope","purl":null,"source":"GHSA-hxxf-q3w9-4xgw"},{"ecosystem":"npm","fixed":["3.7.3"],"introduced":["3.7.2"],"last_affected":[],"package":"eslint-scope","purl":"pkg:npm/eslint-scope","source":"GHSA-hxxf-q3w9-4xgw"}],"products":null,"published":"2018-07-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A malicious version of the eslint-scope npm package steals authentication tokens from .npmrc files, requiring immediate token revocation and package removal.","url":"https://insights.sbomify.com/GHSA-hxxf-q3w9-4xgw/"}