# GHSA-hxxf-q3w9-4xgw: Malicious Package in eslint-scope

> A malicious version of the eslint-scope npm package steals authentication tokens from .npmrc files, requiring immediate token revocation and package removal.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2018

## What is GHSA-hxxf-q3w9-4xgw?

GHSA-hxxf-q3w9-4xgw is a vulnerability in eslint-config-eslint, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Version 3.7.2 of `eslint-scope` was published without authorization and was found to contain malicious code. This code would read the users `.npmrc` file and send any found authentication tokens to 2 remote servers.

## Recommendation

The best course of action if you found this package installed in your environment is to revoke all your npm tokens. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/working_with_tokens#how-to-revoke-tokens

## Which versions are affected by GHSA-hxxf-q3w9-4xgw?

4 open source packages ship an affected version, including eslint-config-eslint and eslint-scope.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eslint-config-eslint` | npm | From 5.0.2 | 6.0.0 |
| `eslint-config-eslint` | npm | From 5.0.2 | 6.0.0 |
| `eslint-scope` | npm | From 3.7.2 | 3.7.3 |
| `eslint-scope` | npm | From 3.7.2 | 3.7.3 |

## How do I fix GHSA-hxxf-q3w9-4xgw?

Upgrade eslint-config-eslint to 6.0.0 or later.

## Is GHSA-hxxf-q3w9-4xgw being exploited?

There is no known exploitation of GHSA-hxxf-q3w9-4xgw in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-hxxf-q3w9-4xgw and fix it if it is affected.

What it is: GHSA-hxxf-q3w9-4xgw is a vulnerability in eslint-config-eslint, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-hxxf-q3w9-4xgw in the wild and no public exploit code.

Affected packages and fixed versions:
- eslint-config-eslint (npm): affected from 5.0.2; fixed in 6.0.0
- eslint-config-eslint (npm): affected from 5.0.2; fixed in 6.0.0
- eslint-scope (npm): affected from 3.7.2; fixed in 3.7.3
- eslint-scope (npm): affected from 3.7.2; fixed in 3.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-hxxf-q3w9-4xgw/ (Markdown: https://insights.sbomify.com/GHSA-hxxf-q3w9-4xgw/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-hxxf-q3w9-4xgw

---
From sbomify Insights: https://insights.sbomify.com/GHSA-hxxf-q3w9-4xgw/
Summaries are generated and may contain mistakes; the official description above is the record.
