# GHSA-j23j-q57m-63v3: Denial of service in DataCommunicator class in Vaadin 8

> An authenticated attacker can cause heap exhaustion and denial of service by requesting excessive data rows in the Vaadin DataCommunicator class.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2021

## What is GHSA-j23j-q57m-63v3?

GHSA-j23j-q57m-63v3 is a denial of service vulnerability in com.vaadin:vaadin-server, published on 13 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Missing check in `DataCommunicator` class in `com.vaadin:vaadin-server` versions 8.0.0 through 8.14.0 (Vaadin 8.0.0 through 8.14.0) allows authenticated network attacker to cause heap exhaustion by requesting too many rows of data.

## Which versions are affected by GHSA-j23j-q57m-63v3?

2 open source packages ship an affected version, including com.vaadin:vaadin-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-server` | Maven | From 8.0.0 | 8.14.1 |
| `com.vaadin:vaadin-server` | Maven | From 8.0.0 | 8.14.1 |

## How do I fix GHSA-j23j-q57m-63v3?

Upgrade com.vaadin:vaadin-server to 8.14.1 or later.

## Is GHSA-j23j-q57m-63v3 being exploited?

There is no known exploitation of GHSA-j23j-q57m-63v3 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-j23j-q57m-63v3 and fix it if it is affected.

What it is: GHSA-j23j-q57m-63v3 is a denial of service vulnerability in com.vaadin:vaadin-server, published on 13 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-j23j-q57m-63v3 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-server (Maven): affected from 8.0.0; fixed in 8.14.1
- com.vaadin:vaadin-server (Maven): affected from 8.0.0; fixed in 8.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-j23j-q57m-63v3/ (Markdown: https://insights.sbomify.com/GHSA-j23j-q57m-63v3/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-j23j-q57m-63v3

---
From sbomify Insights: https://insights.sbomify.com/GHSA-j23j-q57m-63v3/
Summaries are generated and may contain mistakes; the official description above is the record.
