{"answers":{"affected":"2 open source packages ship an affected version, including github.com/pomerium/pomerium.","exploited":"There is no known exploitation of GHSA-j34v-3552-5r7j in the wild and no public exploit code.","fix":"Upgrade github.com/pomerium/pomerium to 0.16.4 or later.","what":"GHSA-j34v-3552-5r7j is a memory corruption vulnerability in github.com/pomerium/pomerium, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-j34v-3552-5r7j and fix it if it is affected.\n\nWhat it is: GHSA-j34v-3552-5r7j is a memory corruption vulnerability in github.com/pomerium/pomerium, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-j34v-3552-5r7j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.16.4\n- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.16.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-j34v-3552-5r7j/ (Markdown: https://insights.sbomify.com/GHSA-j34v-3552-5r7j/index.md)","id":"GHSA-j34v-3552-5r7j","markdown":"https://insights.sbomify.com/GHSA-j34v-3552-5r7j/index.md","name":"GHSA-j34v-3552-5r7j","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Zero Trust Access Proxy","requires_auth":"none","summary":"Attackers can cause denial of service or bypass security controls in Pomerium due to vulnerabilities in its embedded Envoy proxy.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Envoy, which Pomerium is based on, has issued multiple CVEs impacting stability and security.\n\nThough Pomerium may not be vulnerable to all of the issues, it is recommended that all users upgrade to Pomerium v0.16.4 as soon as possible to minimize risk.\n\n### Impact\n\n- Possible DoS or crash\n- Resources available to unauthorized users\n- Pomerium may trust upstream certificates that should not be trusted\n\n### Patches\nPatched in v0.16.4\n\n### Workarounds\nNo\n\n### References\n\n[Envoy Security Announcement](https://groups.google.com/g/envoy-security-announce/c/QBGxoqZdTR4)\n\n* [CVE-2021-43824](https://github.com/envoyproxy/envoy/security/advisories/GHSA-vj5m-rch8-5r2p) (CVSS Score 6.5, Medium): Envoy 1.21.0 and earlier - Potential null pointer dereference when using JWT filter safe_regex match\n* [CVE-2021-43825](https://github.com/envoyproxy/envoy/security/advisories/GHSA-h69p-g6xg-mhhh) (CVSS Score 6.1, Medium): Envoy 1.21.0 and earlier - Use-after-free when response filters increase response data, and increased data exceeds downstream buffer limits.\n* [CVE-2021-43826](https://github.com/envoyproxy/envoy/security/advisories/GHSA-cmx3-fvgf-83mf) (CVSS Score 6.1, Medium): Envoy 1.21.0 and earlier - Use-after-free when tunneling TCP over HTTP, if downstream disconnects during upstream connection establishment\n* [CVE-2022-21654](https://github.com/envoyproxy/envoy/security/advisories/GHSA-5j4x-g36v-m283) (CVSS Score 7.3, High): Envoy 1.7.0 and later - Incorrect configuration handling allows mTLS session re-use without re-validation after validation settings have changed.\n* [CVE-2022-21655](https://github.com/envoyproxy/envoy/security/advisories/GHSA-7r5p-7fmh-jxpg) (CVSS Score 7.5, High): Envoy 1.21 and earlier - Incorrect handling of internal redirects to routes with a direct response entry\n* [CVE-2022-21657](https://github.com/envoyproxy/envoy/security/advisories/GHSA-837m-wjrv-vm5g) (CVSS Score 3.1, Low): Envoy 1.20.1 and earlier - X.509 Extended Key Usage and Trust Purposes bypass\n\n### For more information\nIf you have any questions or comments about this advisory:\n\nOpen an issue in [pomerium/pomerium](https://github.com/pomerium/pomerium/issues)\nEmail us at [security@pomerium.com](mailto:security@pomerium.com)","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Multiple security issues in Pomerium's embedded envoy","id":"GHSA-j34v-3552-5r7j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.16.4"],"introduced":["0"],"last_affected":[],"package":"github.com/pomerium/pomerium","purl":null,"source":"GHSA-j34v-3552-5r7j"},{"ecosystem":"Go","fixed":["0.16.4"],"introduced":["0"],"last_affected":[],"package":"github.com/pomerium/pomerium","purl":"pkg:golang/github.com/pomerium/pomerium","source":"GHSA-j34v-3552-5r7j"}],"products":null,"published":"2022-03-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service or bypass security controls in Pomerium due to vulnerabilities in its embedded Envoy proxy.","url":"https://insights.sbomify.com/GHSA-j34v-3552-5r7j/"}