{"answers":{"affected":"2 open source packages ship an affected version, including omero-web.","exploited":"There is no known exploitation of GHSA-j4gv-6x9v-v23g in the wild and no public exploit code.","fix":"Upgrade omero-web to 5.29.3 or later.","what":"GHSA-j4gv-6x9v-v23g is a cross-site scripting vulnerability in omero-web, published on 24 Nov 2025. It can be exploited over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-j4gv-6x9v-v23g and fix it if it is affected.\n\nWhat it is: GHSA-j4gv-6x9v-v23g is a cross-site scripting vulnerability in omero-web, published on 24 Nov 2025. It can be exploited over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-j4gv-6x9v-v23g in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omero-web (PyPI): affected all versions; fixed in 5.29.3\n- omero-web (PyPI): affected all versions; fixed in 5.29.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-j4gv-6x9v-v23g/ (Markdown: https://insights.sbomify.com/GHSA-j4gv-6x9v-v23g/index.md)","id":"GHSA-j4gv-6x9v-v23g","markdown":"https://insights.sbomify.com/GHSA-j4gv-6x9v-v23g/index.md","name":"GHSA-j4gv-6x9v-v23g","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OMERO.web","requires_auth":"unknown","summary":"OMERO.web is vulnerable to XSS attacks via the jquery-form library, allowing attackers to execute scripts in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nOMERO.web uses the jquery-form library throughout to handle form submission and response processing. Due to some unpatched potential vulnerabilities in jquery-form, OMERO.web 5.29.2 and earlier may be susceptible to XSS attacks.\n\n### Patches\nUser should upgrade OMERO.web to 5.29.3 or higher.\n\n### Workarounds\nNone.\n\n### Resources\nhttps://github.com/jquery-form/form/issues/604","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OMERO.web uses jquery-form library, which may be vulnerable to XSS attack","id":"GHSA-j4gv-6x9v-v23g","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["5.29.3"],"introduced":["0"],"last_affected":[],"package":"omero-web","purl":null,"source":"GHSA-j4gv-6x9v-v23g"},{"ecosystem":"PyPI","fixed":["5.29.3"],"introduced":["0"],"last_affected":[],"package":"omero-web","purl":"pkg:pypi/omero-web","source":"GHSA-j4gv-6x9v-v23g"}],"products":null,"published":"2025-11-24","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"OMERO.web is vulnerable to XSS attacks via the jquery-form library, allowing attackers to execute scripts in user browsers.","url":"https://insights.sbomify.com/GHSA-j4gv-6x9v-v23g/"}