{"answers":{"affected":"2 open source packages ship an affected version, including base64-url.","exploited":"There is no known exploitation of GHSA-j4mr-9xw3-c9jx in the wild and no public exploit code.","fix":"Upgrade base64-url to 2.0.0 or later.","what":"GHSA-j4mr-9xw3-c9jx is a vulnerability in base64-url, published on 31 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-j4mr-9xw3-c9jx and fix it if it is affected.\n\nWhat it is: GHSA-j4mr-9xw3-c9jx is a vulnerability in base64-url, published on 31 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-j4mr-9xw3-c9jx in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- base64-url (npm): affected all versions; fixed in 2.0.0\n- base64-url (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-j4mr-9xw3-c9jx/ (Markdown: https://insights.sbomify.com/GHSA-j4mr-9xw3-c9jx/index.md)","id":"GHSA-j4mr-9xw3-c9jx","markdown":"https://insights.sbomify.com/GHSA-j4mr-9xw3-c9jx/index.md","name":"GHSA-j4mr-9xw3-c9jx","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js base64 library","requires_auth":"none","summary":"An out-of-bounds read vulnerability in the base64-url library allows attackers to disclose sensitive memory contents by passing numeric inputs.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `base64-url` before 2.0.0 are vulnerable to out-of-bounds read as it allocates uninitialized Buffers when number is passed in input.\n\n## Recommendation\n\nUpdate to version 2.0.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Out-of-bounds Read in base64-url","id":"GHSA-j4mr-9xw3-c9jx","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"base64-url","purl":null,"source":"GHSA-j4mr-9xw3-c9jx"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"base64-url","purl":"pkg:npm/base64-url","source":"GHSA-j4mr-9xw3-c9jx"}],"products":null,"published":"2019-05-31","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An out-of-bounds read vulnerability in the base64-url library allows attackers to disclose sensitive memory contents by passing numeric inputs.","url":"https://insights.sbomify.com/GHSA-j4mr-9xw3-c9jx/"}