GHSA-j59f-6m4q-62h6 Improper Key Verification in ipns
Attackers can bypass IPNS key verification, allowing unauthorized access or data integrity violations in applications using the vulnerable library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-j59f-6m4q-62h6?
GHSA-j59f-6m4q-62h6 is an authentication bypass vulnerability in ipns, published on 30 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Versions 0.1.1 or 0.1.2 of ipns are vulnerable to improper key validation. This is due to the public key verification was not being performed properly, resulting in any key being valid.
Recommendation
Update to version 0.1.3 or later.
Which versions are affected by GHSA-j59f-6m4q-62h6?
2 open source packages ship an affected version, including ipns.
| Package | Affected | Fixed in |
|---|---|---|
ipns npm | All versions | 0.1.3 |
ipns npm | All versions | 0.1.3 |
How do I fix GHSA-j59f-6m4q-62h6?
Upgrade ipns to 0.1.3 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is GHSA-j59f-6m4q-62h6 being exploited?
There is no known exploitation of GHSA-j59f-6m4q-62h6 in the wild and no public exploit code.