{"answers":{"affected":"2 open source packages ship an affected version, including ipns.","exploited":"There is no known exploitation of GHSA-j59f-6m4q-62h6 in the wild and no public exploit code.","fix":"Upgrade ipns to 0.1.3 or later.","what":"GHSA-j59f-6m4q-62h6 is an authentication bypass vulnerability in ipns, published on 30 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-j59f-6m4q-62h6 and fix it if it is affected.\n\nWhat it is: GHSA-j59f-6m4q-62h6 is an authentication bypass vulnerability in ipns, published on 30 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-j59f-6m4q-62h6 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ipns (npm): affected all versions; fixed in 0.1.3\n- ipns (npm): affected all versions; fixed in 0.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-j59f-6m4q-62h6/ (Markdown: https://insights.sbomify.com/GHSA-j59f-6m4q-62h6/index.md)","id":"GHSA-j59f-6m4q-62h6","markdown":"https://insights.sbomify.com/GHSA-j59f-6m4q-62h6/index.md","name":"GHSA-j59f-6m4q-62h6","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"IPNS JavaScript library","requires_auth":"none","summary":"Attackers can bypass IPNS key verification, allowing unauthorized access or data integrity violations in applications using the vulnerable library.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions 0.1.1 or 0.1.2 of `ipns` are vulnerable to improper key validation. This is due to the public key verification was not being performed properly, resulting in any key being valid.\n\n## Recommendation\n\nUpdate to version 0.1.3 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Improper Key Verification in ipns","id":"GHSA-j59f-6m4q-62h6","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.1.3"],"introduced":["0"],"last_affected":[],"package":"ipns","purl":null,"source":"GHSA-j59f-6m4q-62h6"},{"ecosystem":"npm","fixed":["0.1.3"],"introduced":["0"],"last_affected":[],"package":"ipns","purl":"pkg:npm/ipns","source":"GHSA-j59f-6m4q-62h6"}],"products":null,"published":"2019-05-30","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass IPNS key verification, allowing unauthorized access or data integrity violations in applications using the vulnerable library.","url":"https://insights.sbomify.com/GHSA-j59f-6m4q-62h6/"}