# GHSA-j59f-6m4q-62h6: Improper Key Verification in ipns

> Attackers can bypass IPNS key verification, allowing unauthorized access or data integrity violations in applications using the vulnerable library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2019

## What is GHSA-j59f-6m4q-62h6?

GHSA-j59f-6m4q-62h6 is an authentication bypass vulnerability in ipns, published on 30 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions 0.1.1 or 0.1.2 of `ipns` are vulnerable to improper key validation. This is due to the public key verification was not being performed properly, resulting in any key being valid.

## Recommendation

Update to version 0.1.3 or later.

## Which versions are affected by GHSA-j59f-6m4q-62h6?

2 open source packages ship an affected version, including ipns.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ipns` | npm | All versions | 0.1.3 |
| `ipns` | npm | All versions | 0.1.3 |

## How do I fix GHSA-j59f-6m4q-62h6?

Upgrade ipns to 0.1.3 or later.

## Is GHSA-j59f-6m4q-62h6 being exploited?

There is no known exploitation of GHSA-j59f-6m4q-62h6 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-j59f-6m4q-62h6 and fix it if it is affected.

What it is: GHSA-j59f-6m4q-62h6 is an authentication bypass vulnerability in ipns, published on 30 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-j59f-6m4q-62h6 in the wild and no public exploit code.

Affected packages and fixed versions:
- ipns (npm): affected all versions; fixed in 0.1.3
- ipns (npm): affected all versions; fixed in 0.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-j59f-6m4q-62h6/ (Markdown: https://insights.sbomify.com/GHSA-j59f-6m4q-62h6/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-j59f-6m4q-62h6

---
From sbomify Insights: https://insights.sbomify.com/GHSA-j59f-6m4q-62h6/
Summaries are generated and may contain mistakes; the official description above is the record.
