{"answers":{"affected":"2 open source packages ship an affected version, including @progress/kendo-angular-editor.","exploited":"There is no known exploitation of GHSA-j7wp-vjj6-cp5m in the wild and no public exploit code.","fix":"Upgrade @progress/kendo-angular-editor to 1.2.3 or later.","what":"GHSA-j7wp-vjj6-cp5m is a cross-site scripting vulnerability in @progress/kendo-angular-editor, published on 11 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-j7wp-vjj6-cp5m and fix it if it is affected.\n\nWhat it is: GHSA-j7wp-vjj6-cp5m is a cross-site scripting vulnerability in @progress/kendo-angular-editor, published on 11 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-j7wp-vjj6-cp5m in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @progress/kendo-angular-editor (npm): affected all versions; fixed in 1.2.3\n- @progress/kendo-angular-editor (npm): affected all versions; fixed in 1.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-j7wp-vjj6-cp5m/ (Markdown: https://insights.sbomify.com/GHSA-j7wp-vjj6-cp5m/index.md)","id":"GHSA-j7wp-vjj6-cp5m","markdown":"https://insights.sbomify.com/GHSA-j7wp-vjj6-cp5m/index.md","name":"GHSA-j7wp-vjj6-cp5m","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Angular UI library","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary JavaScript in the victim's browser by injecting malicious event handlers into the Kendo Angular Editor component.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Kendo UI for Angular Editor Component (npm package @progress/kendo-angular-editor) before version 1.2.3 is vulnerable to Cross-Site Scripting. When the Editor content contains potentially malicious scripts in element event handlers, they get executed.\nAdding the following content to the Editor value demonstrates the issue: `\u003cimg src=\"\" onerror=alert(document.domain)\u003e`.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in @progress/kendo-angular-editor","id":"GHSA-j7wp-vjj6-cp5m","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.2.3"],"introduced":["0"],"last_affected":[],"package":"@progress/kendo-angular-editor","purl":null,"source":"GHSA-j7wp-vjj6-cp5m"},{"ecosystem":"npm","fixed":["1.2.3"],"introduced":["0"],"last_affected":[],"package":"@progress/kendo-angular-editor","purl":"pkg:npm/%40progress/kendo-angular-editor","source":"GHSA-j7wp-vjj6-cp5m"}],"products":null,"published":"2020-08-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can execute arbitrary JavaScript in the victim's browser by injecting malicious event handlers into the Kendo Angular Editor component.","url":"https://insights.sbomify.com/GHSA-j7wp-vjj6-cp5m/"}