{"answers":{"affected":"2 open source packages ship an affected version, including aws-sdk.","exploited":"There is no known exploitation of GHSA-j965-2qgj-vjmq in the wild and no public exploit code.","fix":"No fix has been published for GHSA-j965-2qgj-vjmq yet. Limit exposure of the affected software until one is available.","what":"GHSA-j965-2qgj-vjmq is a server-side request forgery vulnerability in aws-sdk, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-j965-2qgj-vjmq and fix it if it is affected.\n\nWhat it is: GHSA-j965-2qgj-vjmq is a server-side request forgery vulnerability in aws-sdk, published on 8 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-j965-2qgj-vjmq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-sdk (npm): affected from 2.0.0 up to 3.0.0; no fix listed\n- aws-sdk (npm): affected from 2.0.0 up to 3.0.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-j965-2qgj-vjmq/ (Markdown: https://insights.sbomify.com/GHSA-j965-2qgj-vjmq/index.md)","id":"GHSA-j965-2qgj-vjmq","markdown":"https://insights.sbomify.com/GHSA-j965-2qgj-vjmq/index.md","name":"GHSA-j965-2qgj-vjmq","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS JavaScript SDK","requires_auth":"none","summary":"Attackers with environment access can manipulate region parameters to route AWS API calls to malicious hosts, requiring migration to SDK v3 or input validation.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"CVSSv3.1 Rating: 3.7 (LOW)\n\nSummary\nThis notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value. Per the AWS shared responsibility model, customer applications should protect instances appropriately, or implement proper input sanitization checks. The AWS SDK for JavaScript v2 reached end-of-support on September 8, 2025, but a defense-in-depth enhancement has been implemented in AWS SDK for JavaScript v3. Please migrate to that version.\n\nImpact\nCustomer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. While the SDK itself is functioning as designed, we recommend customers migrate to AWS SDK for JavaScript v3 for continued support and enhanced security features.\n\nImpacted versions: All versions of AWS SDK for JavaScript v2\n\nPatches\nNo security patch is required, this is an informational advisory.\n\nWorkarounds\n- Implement proper input sanitization in your application code\n- Migrate to AWS SDK for JavaScript v3\n- Follow AWS security best practices for SDK configuration\n\nReferences\nContact AWS Security via the vulnerability reporting page or email [aws-security@amazon.com](mailto:aws-security@amazon.com).\n\nAcknowledgement\nAWS Security thanks Guy Arazi for bringing these customer security considerations to our attention through the coordinated disclosure process.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"JavaScript SDK v2 users should add validation to the region parameter value in or migrate to v3","id":"GHSA-j965-2qgj-vjmq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":[],"introduced":["2.0.0"],"last_affected":["3.0.0"],"package":"aws-sdk","purl":null,"source":"GHSA-j965-2qgj-vjmq"},{"ecosystem":"npm","fixed":[],"introduced":["2.0.0"],"last_affected":["3.0.0"],"package":"aws-sdk","purl":"pkg:npm/aws-sdk","source":"GHSA-j965-2qgj-vjmq"}],"products":null,"published":"2026-01-08","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers with environment access can manipulate region parameters to route AWS API calls to malicious hosts, requiring migration to SDK v3 or input validation.","url":"https://insights.sbomify.com/GHSA-j965-2qgj-vjmq/"}