{"answers":{"affected":"2 open source packages ship an affected version, including node-os-utils.","exploited":"There is no known exploitation of GHSA-j9f8-8h89-j69x in the wild and no public exploit code.","fix":"Upgrade node-os-utils to 1.1.0 or later.","what":"GHSA-j9f8-8h89-j69x is a command injection vulnerability in node-os-utils, published on 11 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-j9f8-8h89-j69x and fix it if it is affected.\n\nWhat it is: GHSA-j9f8-8h89-j69x is a command injection vulnerability in node-os-utils, published on 11 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-j9f8-8h89-j69x in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-os-utils (npm): affected all versions; fixed in 1.1.0\n- node-os-utils (npm): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-j9f8-8h89-j69x/ (Markdown: https://insights.sbomify.com/GHSA-j9f8-8h89-j69x/index.md)","id":"GHSA-j9f8-8h89-j69x","markdown":"https://insights.sbomify.com/GHSA-j9f8-8h89-j69x/index.md","name":"GHSA-j9f8-8h89-j69x","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js OS utility library","requires_auth":"none","summary":"Attackers can execute arbitrary commands on servers using the node-os-utils library due to insufficient input validation.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `node-os-utils` prior to 1.1.0 are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution.\n\n## Recommendation\n\nUpgrade to version 1.1.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Remote Code Execution in node-os-utils","id":"GHSA-j9f8-8h89-j69x","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"node-os-utils","purl":null,"source":"GHSA-j9f8-8h89-j69x"},{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"node-os-utils","purl":"pkg:npm/node-os-utils","source":"GHSA-j9f8-8h89-j69x"}],"products":null,"published":"2019-06-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary commands on servers using the node-os-utils library due to insufficient input validation.","url":"https://insights.sbomify.com/GHSA-j9f8-8h89-j69x/"}