{"answers":{"affected":"4 open source packages ship an affected version, including cakephp/cakephp.","exploited":"There is no known exploitation of GHSA-j9q2-f9q7-jhgq in the wild and no public exploit code.","fix":"Upgrade cakephp/cakephp to a fixed version for your release line: 1.3.18 or 2.4.8.","what":"GHSA-j9q2-f9q7-jhgq is a missing authorization vulnerability in cakephp/cakephp, published on 20 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-j9q2-f9q7-jhgq and fix it if it is affected.\n\nWhat it is: GHSA-j9q2-f9q7-jhgq is a missing authorization vulnerability in cakephp/cakephp, published on 20 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-j9q2-f9q7-jhgq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cakephp/cakephp (Packagist): affected from 1.3.0; fixed in 1.3.18\n- cakephp/cakephp (Packagist): affected from 1.3.0; fixed in 1.3.18\n- cakephp/cakephp (Packagist): affected from 2.0.0; fixed in 2.4.8\n- cakephp/cakephp (Packagist): affected from 2.0.0; fixed in 2.4.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-j9q2-f9q7-jhgq/ (Markdown: https://insights.sbomify.com/GHSA-j9q2-f9q7-jhgq/index.md)","id":"GHSA-j9q2-f9q7-jhgq","markdown":"https://insights.sbomify.com/GHSA-j9q2-f9q7-jhgq/index.md","name":"GHSA-j9q2-f9q7-jhgq","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"CakePHP framework","requires_auth":"low_privilege","summary":"Attackers can submit forms to unauthorized actions, potentially causing mass assignment issues in CakePHP applications using SecurityComponent.","user_interaction":"required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Prior to versions 2.4.8 and 1.3.18, forms secured by SecurityComponent could be submitted to any action without triggering SecurityComponent’s tampering protection. If an application contained multiple POST forms to manipulate the same models, it could be vulnerable to mass assignment issues.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"CakePHP SecurityComponent cross form submission issue","id":"GHSA-j9q2-f9q7-jhgq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.3.18"],"introduced":["1.3.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-j9q2-f9q7-jhgq"},{"ecosystem":"Packagist","fixed":["1.3.18"],"introduced":["1.3.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-j9q2-f9q7-jhgq"},{"ecosystem":"Packagist","fixed":["2.4.8"],"introduced":["2.0.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-j9q2-f9q7-jhgq"},{"ecosystem":"Packagist","fixed":["2.4.8"],"introduced":["2.0.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-j9q2-f9q7-jhgq"}],"products":null,"published":"2023-01-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can submit forms to unauthorized actions, potentially causing mass assignment issues in CakePHP applications using SecurityComponent.","url":"https://insights.sbomify.com/GHSA-j9q2-f9q7-jhgq/"}