# GHSA-j9wf-6r2x-hqmx: Centrifugo v6.6.0 dependency vulnerabilities

> Centrifugo server is vulnerable due to outdated Go runtime and webtransport dependencies, requiring an upgrade to mitigate critical security risks.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Also known as:** GO-2026-4528

## What is GHSA-j9wf-6r2x-hqmx?

GHSA-j9wf-6r2x-hqmx is a vulnerability in github.com/centrifugal/centrifugo, published on 19 Feb 2026. It can be exploited over the network.

### Official description

### Summary                                                                                                                                                                                              
                                                                                                                                                                                                           
  Centrifugo v6.6.0 binary is compiled with **Go 1.25.5** and                                                                                                                       
  statically links `github.com/quic-go/webtransport-go v0.9.0`, having **7 known                                                                                                                      
  CVEs**

  **Go standard library — compiled with Go 1.25.5:**

  | CVE | Severity | CVSS | Fixed In |
  |-----|----------|------|----------|
  | CVE-2025-68121 | **CRITICAL** | 10.0 | Go 1.25.7, 1.24.13 |
  | CVE-2025-61726 | HIGH | 7.5 | Go 1.25.6, 1.24.12 |
  | CVE-2025-61728 | MEDIUM | 6.5 | Go 1.25.6, 1.24.12 |
  | CVE-2025-61730 | MEDIUM | 5.3 | Go 1.25.6, 1.24.12 |

  **Direct dependency `github.com/quic-go/webtransport-go` — pinned at v0.9.0
  (`go.mod` line 34):**

  | CVE | Severity | CVSS | Fixed In |
  |-----|----------|------|----------|
  | CVE-2026-21434 | MEDIUM | 5.3 | webtransport-go v0.10.0 |
  | CVE-2026-21435 | MEDIUM | 5.3 | webtransport-go v0.10.0 |
  | CVE-2026-21438 | MEDIUM | 5.3 | webtransport-go v0.10.0 |

## Which versions are affected by GHSA-j9wf-6r2x-hqmx?

7 open source packages ship an affected version, including github.com/centrifugal/centrifugo/v6, github.com/centrifugal/centrifugo and github.com/centrifugal/centrifugo/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/centrifugal/centrifugo/v6` | Go | All versions | 6.6.1 |
| `github.com/centrifugal/centrifugo/v6` | Go | All versions | 6.6.1 |
| `github.com/centrifugal/centrifugo/v6` | Go | All versions | 6.6.1 |
| `github.com/centrifugal/centrifugo` | Go | All versions | None |
| `github.com/centrifugal/centrifugo/v3` | Go | All versions | None |
| `github.com/centrifugal/centrifugo/v4` | Go | All versions | None |
| `github.com/centrifugal/centrifugo/v5` | Go | All versions | None |

## How do I fix GHSA-j9wf-6r2x-hqmx?

Upgrade github.com/centrifugal/centrifugo/v6 to 6.6.1 or later.

## Is GHSA-j9wf-6r2x-hqmx being exploited?

There is no known exploitation of GHSA-j9wf-6r2x-hqmx in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-j9wf-6r2x-hqmx and fix it if it is affected.

What it is: GHSA-j9wf-6r2x-hqmx is a vulnerability in github.com/centrifugal/centrifugo, published on 19 Feb 2026. It can be exploited over the network.
Exploitation: There is no known exploitation of GHSA-j9wf-6r2x-hqmx in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/centrifugal/centrifugo/v6 (Go): affected all versions; fixed in 6.6.1
- github.com/centrifugal/centrifugo/v6 (Go): affected all versions; fixed in 6.6.1
- github.com/centrifugal/centrifugo/v6 (Go): affected all versions; fixed in 6.6.1
- github.com/centrifugal/centrifugo (Go): affected all versions; no fix listed
- github.com/centrifugal/centrifugo/v3 (Go): affected all versions; no fix listed
- github.com/centrifugal/centrifugo/v4 (Go): affected all versions; no fix listed
- github.com/centrifugal/centrifugo/v5 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-j9wf-6r2x-hqmx/ (Markdown: https://insights.sbomify.com/GHSA-j9wf-6r2x-hqmx/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-j9wf-6r2x-hqmx

---
From sbomify Insights: https://insights.sbomify.com/GHSA-j9wf-6r2x-hqmx/
Summaries are generated and may contain mistakes; the official description above is the record.
