# GHSA-j9wr-49vq-rm5g: Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19

> Attackers can access server-side application classes and resources via crafted HTTP requests in Vaadin OSGi integrations.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2021

## What is GHSA-j9wr-49vq-rm5g?

GHSA-j9wr-49vq-rm5g is a vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in OSGi integration in `com.vaadin:flow-server` versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.

- https://vaadin.com/security/cve-2021-31407

## Which versions are affected by GHSA-j9wr-49vq-rm5g?

4 open source packages ship an affected version, including com.vaadin:vaadin-bom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin-bom` | Maven | From 12.0.0 | 14.4.10 |
| `com.vaadin:vaadin-bom` | Maven | From 12.0.0 | 14.4.10 |
| `com.vaadin:vaadin-bom` | Maven | From 19.0.0 | 19.0.1 |
| `com.vaadin:vaadin-bom` | Maven | From 19.0.0 | 19.0.1 |

## How do I fix GHSA-j9wr-49vq-rm5g?

Upgrade com.vaadin:vaadin-bom to a fixed version for your release line: 14.4.10 or 19.0.1.

## Is GHSA-j9wr-49vq-rm5g being exploited?

There is no known exploitation of GHSA-j9wr-49vq-rm5g in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-j9wr-49vq-rm5g and fix it if it is affected.

What it is: GHSA-j9wr-49vq-rm5g is a vulnerability in com.vaadin:vaadin-bom, published on 19 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-j9wr-49vq-rm5g in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin-bom (Maven): affected from 12.0.0; fixed in 14.4.10
- com.vaadin:vaadin-bom (Maven): affected from 12.0.0; fixed in 14.4.10
- com.vaadin:vaadin-bom (Maven): affected from 19.0.0; fixed in 19.0.1
- com.vaadin:vaadin-bom (Maven): affected from 19.0.0; fixed in 19.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-j9wr-49vq-rm5g/ (Markdown: https://insights.sbomify.com/GHSA-j9wr-49vq-rm5g/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-j9wr-49vq-rm5g

---
From sbomify Insights: https://insights.sbomify.com/GHSA-j9wr-49vq-rm5g/
Summaries are generated and may contain mistakes; the official description above is the record.
