{"answers":{"affected":"2 open source packages ship an affected version, including @cyyynthia/tokenize.","exploited":"There is no known exploitation of GHSA-jcjx-c3j3-44pr in the wild and no public exploit code.","fix":"Upgrade @cyyynthia/tokenize to 1.1.3 or later.","what":"GHSA-jcjx-c3j3-44pr is a vulnerability in @cyyynthia/tokenize, published on 10 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-jcjx-c3j3-44pr and fix it if it is affected.\n\nWhat it is: GHSA-jcjx-c3j3-44pr is a vulnerability in @cyyynthia/tokenize, published on 10 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-jcjx-c3j3-44pr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cyyynthia/tokenize (npm): affected from 1.1.0; fixed in 1.1.3\n- @cyyynthia/tokenize (npm): affected from 1.1.0; fixed in 1.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jcjx-c3j3-44pr/ (Markdown: https://insights.sbomify.com/GHSA-jcjx-c3j3-44pr/index.md)","id":"GHSA-jcjx-c3j3-44pr","markdown":"https://insights.sbomify.com/GHSA-jcjx-c3j3-44pr/index.md","name":"GHSA-jcjx-c3j3-44pr","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript token library","requires_auth":"none","summary":"Attackers can use tokens that never expire due to a generation bug, bypassing session expiration controls in applications using this library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nA bug introduced in version 1.1.0 made Tokenize generate faulty tokens with NaN as a generation date. As a result, tokens would not properly expire and remain valid regardless of the `lastTokenReset` field.\n\n### Patches\nVersion 1.1.3 contains a patch that'll invalidate these faulty tokens and make new ones behave as expected.\n\n### Workarounds\nNone. Tokens do not hold the necessary information to perform invalidation anymore.\n\n### References\nPR #1\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [github.com/cyyynthia/tokenize](https://github.com/cyyynthia/tokenize)\n* Email us at [cynthia@cynthia.dev](mailto:cynthia@cynthia.dev)","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Insufficient Session Expiration in @cyyynthia/tokenize","id":"GHSA-jcjx-c3j3-44pr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.1.3"],"introduced":["1.1.0"],"last_affected":[],"package":"@cyyynthia/tokenize","purl":null,"source":"GHSA-jcjx-c3j3-44pr"},{"ecosystem":"npm","fixed":["1.1.3"],"introduced":["1.1.0"],"last_affected":[],"package":"@cyyynthia/tokenize","purl":"pkg:npm/%40cyyynthia/tokenize","source":"GHSA-jcjx-c3j3-44pr"}],"products":null,"published":"2021-11-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can use tokens that never expire due to a generation bug, bypassing session expiration controls in applications using this library.","url":"https://insights.sbomify.com/GHSA-jcjx-c3j3-44pr/"}