{"answers":{"affected":"2 open source packages ship an affected version, including PowerShell.","exploited":"There is no known exploitation of GHSA-jcmq-5rrv-j2g4 in the wild and no public exploit code.","fix":"Upgrade PowerShell to 7.0.0 or later.","what":"GHSA-jcmq-5rrv-j2g4 is a code injection vulnerability in PowerShell, published on 2 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-jcmq-5rrv-j2g4 and fix it if it is affected.\n\nWhat it is: GHSA-jcmq-5rrv-j2g4 is a code injection vulnerability in PowerShell, published on 2 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-jcmq-5rrv-j2g4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- PowerShell (NuGet): affected all versions; fixed in 7.0.0\n- PowerShell (NuGet): affected all versions; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jcmq-5rrv-j2g4/ (Markdown: https://insights.sbomify.com/GHSA-jcmq-5rrv-j2g4/index.md)","id":"GHSA-jcmq-5rrv-j2g4","markdown":"https://insights.sbomify.com/GHSA-jcmq-5rrv-j2g4/index.md","name":"GHSA-jcmq-5rrv-j2g4","record":{"aliases":[],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"PowerShell Core","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into opening a specially crafted file, potentially gaining full system control.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"# Microsoft Security Advisory CVE-2020-0605: .NET Framework Remote Code Execution Vulnerability\n\n## Executive Summary\n\nA remote code execution vulnerability exists in .NET software when the software fails to check the source markup of a file.\n\nAn attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user. If the current user is logged on with administrative user rights, an attacker could take control of the affected system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.\n\nExploitation of the vulnerability requires that a user open a specially crafted file with an affected version of .NET Framework. In an email attack scenario, an attacker could exploit the vulnerability by sending the specially crafted file to the user and convincing the user to open the file.\n\nThe security update addresses the vulnerability by correcting how .NET Framework checks the source markup of a file.\n\n## Discussion\n\nPlease [open a support question](https://github.com/PowerShell/PowerShell/issues/new?assignees=\u0026labels=Issue-Question\u0026template=Support_Question.md\u0026title=Support+Question) to discuss the PowerShell aspects of this advisory.\nPlease use https://github.com/dotnet/wpf/issues/2424 for discussion of the .NET WPF aspects of this advisory.\n\n## \u003ca name=\"affected-software\"\u003eAffected Software\u003c/a\u003e\n\nThe vulnerability affects PowerShell prior to the following versions:\n\n| PowerShell Core Version | Fixed in          |\n|-------------------------|-------------------|\n| 6.2                     | Not Affected              |\n| 7.0                     | 7.0.0              |\n## Advisory FAQ\n\n### How do I know if I am affected?\n\nIf all of the following are true:\n\n1. Run `pwsh -v`, then, check the version in the table in [Affected Software](#user-content-affected-software) to see if your version of PowerShell is affected.\n1. If you are running a version of PowerShell where the executable is not `pwsh` or `pwsh.exe`, then you are affected.  This only existed for preview version of `7.0`.\n\n### How do I update to an unaffected version?\n\nFollow the instructions at [Installing PowerShell](https://docs.microsoft.com/en-us/powershell/scripting/setup/installing-powershell?view=powershell-7) to install the latest version of PowerShell.\n\n## Other Information\n\n### Reporting Security Issues\n\nIf you have found a potential security issue in PowerShell,\nplease email details to secure@microsoft.com.\n\n### Support\n\nYou can ask questions about this issue on GitHub in the PowerShell organization.\nThis is located at https://github.com/PowerShell/.\nThe Announcements repo (https://github.com/PowerShell/Announcements)\nwill contain this bulletin as an issue and will include a link to a discussion issue where you can ask questions.\n\n### What if the update breaks my script or module?\n\nYou can uninstall the newer version of PowerShell and install the previous version of PowerShell.\nThis should be treated as a temporary measure.\nTherefore, the script or module should be updated to work with the patched version of PowerShell.\n\n### Acknowledgments\n\nSoroush Dalili ([@irsdl](https://twitter.com/irsdl))\n\n### External Links\n\n[CVE-2020-0605](https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-0605)\n\n### Revisions\n\n\u003c!-- TBD: update date --\u003e\nV1.0 (March 10, 2020): Advisory published.\n\n*Version 1.0*\n*Last Updated 2020-03-10*","ecosystems":["NuGet"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"PowerShell is subject to remote code execution vulnerability","id":"GHSA-jcmq-5rrv-j2g4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"PowerShell","purl":null,"source":"GHSA-jcmq-5rrv-j2g4"},{"ecosystem":"NuGet","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"PowerShell","purl":"pkg:nuget/PowerShell","source":"GHSA-jcmq-5rrv-j2g4"}],"products":null,"published":"2024-02-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code by tricking users into opening a specially crafted file, potentially gaining full system control.","url":"https://insights.sbomify.com/GHSA-jcmq-5rrv-j2g4/"}