{"answers":{"affected":"4 open source packages ship an affected version, including zoo-kcl and kcl-lib.","exploited":"There is no known exploitation of GHSA-jgvr-6x5w-hx5w in the wild and no public exploit code.","fix":"Upgrade zoo-kcl to 0.3.129 or later.","what":"GHSA-jgvr-6x5w-hx5w is a denial of service vulnerability in zoo-kcl, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-jgvr-6x5w-hx5w and fix it if it is affected.\n\nWhat it is: GHSA-jgvr-6x5w-hx5w is a denial of service vulnerability in zoo-kcl, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-jgvr-6x5w-hx5w in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zoo-kcl (PyPI): affected all versions; fixed in 0.3.129\n- zoo-kcl (PyPI): affected all versions; fixed in 0.3.129\n- kcl-lib (crates.io): affected all versions; fixed in 0.3.129\n- kcl-lib (crates.io): affected all versions; fixed in 0.3.129\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jgvr-6x5w-hx5w/ (Markdown: https://insights.sbomify.com/GHSA-jgvr-6x5w-hx5w/index.md)","id":"GHSA-jgvr-6x5w-hx5w","markdown":"https://insights.sbomify.com/GHSA-jgvr-6x5w-hx5w/index.md","name":"GHSA-jgvr-6x5w-hx5w","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"KCL parsing library","requires_auth":"none","summary":"Attackers can cause a denial of service by submitting deeply nested parentheses in KCL programs, crashing the parser via stack overflow.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nFeeding a KCL program that wraps an expression in deep, unnecessary parentheses triggers the parser’s recursive `expression` -\u003e `unnecessarily_bracketed` -\u003e `expression` path. With enough nesting, the call stack grows until it exceeds the process stack limit, causing a stack overflow.","ecosystems":["PyPI","crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Zoo Design Studio: Recursive KCL parsing is vulnerable to denial-of-service","id":"GHSA-jgvr-6x5w-hx5w","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.3.129"],"introduced":["0"],"last_affected":[],"package":"zoo-kcl","purl":null,"source":"GHSA-jgvr-6x5w-hx5w"},{"ecosystem":"PyPI","fixed":["0.3.129"],"introduced":["0"],"last_affected":[],"package":"zoo-kcl","purl":"pkg:pypi/zoo-kcl","source":"GHSA-jgvr-6x5w-hx5w"},{"ecosystem":"crates.io","fixed":["0.3.129"],"introduced":["0"],"last_affected":[],"package":"kcl-lib","purl":null,"source":"GHSA-jgvr-6x5w-hx5w"},{"ecosystem":"crates.io","fixed":["0.3.129"],"introduced":["0"],"last_affected":[],"package":"kcl-lib","purl":"pkg:cargo/kcl-lib","source":"GHSA-jgvr-6x5w-hx5w"}],"products":null,"published":"2026-08-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause a denial of service by submitting deeply nested parentheses in KCL programs, crashing the parser via stack overflow.","url":"https://insights.sbomify.com/GHSA-jgvr-6x5w-hx5w/"}