GHSA-jm77-qphf-c4w8 pyca/cryptography's wheels include vulnerable OpenSSL
The pyca/cryptography library bundles vulnerable OpenSSL versions, exposing users to multiple security risks unless they upgrade to a patched release.
- Exploited in the wild
- Not known
- Login needed
- Not stated
- Attackable
- Not stated
- Victim action needed
- Not stated
- Fix
- Available
What is GHSA-jm77-qphf-c4w8?
GHSA-jm77-qphf-c4w8 is a vulnerability in cryptography, published on 1 Aug 2023.
Official description
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.8-41.0.2 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230731.txt, https://www.openssl.org/news/secadv/20230719.txt, and https://www.openssl.org/news/secadv/20230714.txt.
If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Which versions are affected by GHSA-jm77-qphf-c4w8?
2 open source packages ship an affected version, including cryptography.
| Package | Affected | Fixed in |
|---|---|---|
cryptography PyPI | From 0.8 | 41.0.3 |
cryptography PyPI | From 0.8 | 41.0.3 |
How do I fix GHSA-jm77-qphf-c4w8?
Upgrade cryptography to 41.0.3 or later.
Is GHSA-jm77-qphf-c4w8 being exploited?
There is no known exploitation of GHSA-jm77-qphf-c4w8 in the wild and no public exploit code.