{"answers":{"affected":"2 open source packages ship an affected version, including cryptography.","exploited":"There is no known exploitation of GHSA-jm77-qphf-c4w8 in the wild and no public exploit code.","fix":"Upgrade cryptography to 41.0.3 or later.","what":"GHSA-jm77-qphf-c4w8 is a vulnerability in cryptography, published on 1 Aug 2023."},"fix_prompt":"Check this codebase for GHSA-jm77-qphf-c4w8 and fix it if it is affected.\n\nWhat it is: GHSA-jm77-qphf-c4w8 is a vulnerability in cryptography, published on 1 Aug 2023. \nExploitation: There is no known exploitation of GHSA-jm77-qphf-c4w8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cryptography (PyPI): affected from 0.8; fixed in 41.0.3\n- cryptography (PyPI): affected from 0.8; fixed in 41.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-jm77-qphf-c4w8/ (Markdown: https://insights.sbomify.com/GHSA-jm77-qphf-c4w8/index.md)","id":"GHSA-jm77-qphf-c4w8","markdown":"https://insights.sbomify.com/GHSA-jm77-qphf-c4w8/index.md","name":"GHSA-jm77-qphf-c4w8","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify","denial_of_service","security_bypass"],"network_reachable":"unknown","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"unknown","summary":"The pyca/cryptography library bundles vulnerable OpenSSL versions, exposing users to multiple security risks unless they upgrade to a patched release.","user_interaction":"unknown","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 0.8-41.0.2 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230731.txt, https://www.openssl.org/news/secadv/20230719.txt, and https://www.openssl.org/news/secadv/20230714.txt.\n\nIf you are building cryptography source (\"sdist\") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"pyca/cryptography's wheels include vulnerable OpenSSL","id":"GHSA-jm77-qphf-c4w8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["41.0.3"],"introduced":["0.8"],"last_affected":[],"package":"cryptography","purl":null,"source":"GHSA-jm77-qphf-c4w8"},{"ecosystem":"PyPI","fixed":["41.0.3"],"introduced":["0.8"],"last_affected":[],"package":"cryptography","purl":"pkg:pypi/cryptography","source":"GHSA-jm77-qphf-c4w8"}],"products":null,"published":"2023-08-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The pyca/cryptography library bundles vulnerable OpenSSL versions, exposing users to multiple security risks unless they upgrade to a patched release.","url":"https://insights.sbomify.com/GHSA-jm77-qphf-c4w8/"}